Bug 968973 - [RESTAPI] Cookies are being set even when not using persistent authentication
[RESTAPI] Cookies are being set even when not using persistent authentication
Status: CLOSED ERRATA
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-restapi (Show other bugs)
3.2.0
Unspecified Unspecified
unspecified Severity unspecified
: ---
: 3.2.1
Assigned To: Ravi Nori
Barak Dagan
infra
: ZStream
Depends On: 962730
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-30 07:57 EDT by Idith Tal-Kohen
Modified: 2016-02-10 14:13 EST (History)
14 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Previously, cookies were being set in the REST-API regardless of using "Prefer: persistent-auth" when sending a request. Now, cookies are only set when "Prefer: persistent-auth" is not specified.
Story Points: ---
Clone Of: 962730
Environment:
Last Closed: 2013-07-16 09:38:28 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Infra
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 14891 None None None Never
oVirt gerrit 15173 None None None Never

  None (edit)
Comment 2 Barak Dagan 2013-07-02 05:05:38 EDT
Verified on SF18.2

>curl -X GET -H "Accept: application/xml" -u USER:PASS https://RHEVM:443/api -k --header "Prefer: ''" -c cookie.txt
>ls cookie.txt
ls: cannot access cookie.txt: No such file or directory


>curl -X GET -H "Accept: application/xml" -u USER:PASS https://RHEVM:443/api -k -c cookie.txt
>ls cookie.txt
ls: cannot access cookie.txt: No such file or directory


>curl -X GET -H "Accept: application/xml" -u USER:PASS https://RHEVM:443/api -k --header "Prefer: persistent-auth" -c cookie.txt
>ls cookie.txt
cookie.txt
Comment 4 errata-xmlrpc 2013-07-16 09:38:28 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1048.html

Note You need to log in before you can comment on or make changes to this bug.