Bug 968974 - ImportError: IPython requires PyQt4 >= 4.7, found 4.10.1
ImportError: IPython requires PyQt4 >= 4.7, found 4.10.1
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: spyder (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Radek Novacek
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-30 08:02 EDT by Neal Becker
Modified: 2016-11-30 19:31 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-30 08:12:12 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Neal Becker 2013-05-30 08:02:37 EDT
Description of problem:

Just tried spyder-2.2.0-1.fc18.noarch.  I get:


spyder
Traceback (most recent call last):
  File "/usr/bin/spyder", line 3, in <module>
    start_app.main()
  File "/usr/lib/python2.7/site-packages/spyderlib/start_app.py", line 72, in main
    from spyderlib import spyder
  File "/usr/lib/python2.7/site-packages/spyderlib/spyder.py", line 100, in <module>
    from spyderlib.plugins.inspector import ObjectInspector
  File "/usr/lib/python2.7/site-packages/spyderlib/plugins/inspector.py", line 36, in <module>
    from spyderlib.widgets.ipython import IPythonControlWidget
  File "/usr/lib/python2.7/site-packages/spyderlib/widgets/ipython.py", line 12, in <module>
    from IPython.frontend.qt.console.rich_ipython_widget import RichIPythonWidget
  File "/home/nbecker/.local/lib/python2.7/site-packages/IPython/frontend/qt/console/rich_ipython_widget.py", line 15, in <module>
    from IPython.external.qt import QtCore, QtGui
  File "/home/nbecker/.local/lib/python2.7/site-packages/IPython/external/qt.py", line 53, in <module>
    raise ImportError("IPython requires PyQt4 >= 4.7, found %s"%QtCore.PYQT_VERSION_STR)
ImportError: IPython requires PyQt4 >= 4.7, found 4.10.1

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 Neal Becker 2013-05-30 08:12:12 EDT
Sorry, I had a bad ipython installation.  Closing.

Note You need to log in before you can comment on or make changes to this bug.