Bug 969045 - [RFE] consumer group CLI should support errata and package group install
[RFE] consumer group CLI should support errata and package group install
Status: CLOSED UPSTREAM
Product: Pulp
Classification: Community
Component: user-experience (Show other bugs)
Master
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: pulp-bugs
Preethi Thomas
: FutureFeature, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-30 10:39 EDT by Preethi Thomas
Modified: 2015-02-28 18:40 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-02-18 20:11:05 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Pulp Redmine 193 None None None Never

  None (edit)
Description Preethi Thomas 2013-05-30 10:39:13 EDT
Description of problem:
Looks like there is no support for errata and package group install on consumer group.


Version-Release number of selected component (if applicable):

pulp-server-2.1.2-0.1.beta.el6.noarch
How reproducible:
always

Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 Preethi Thomas 2013-05-30 15:04:50 EDT
Looks like the REST API is workig. CLI is missing though. Changing it for CLI

Here is POST for package group and errata install on consumer groups

pic.POST('/v2/consumer_groups/consumer-grp/actions/content/install/',body={'units':[{'unit_key':{'name':'haskell'},'type_id':'package_group'}], 'options':{} })


pic.POST('/v2/consumer_groups/consumer-grp/actions/content/install/',body={'units':[{'unit_key':{'id':'grinder_test_4'},'type_id':'erratum'}], 'options':{} })
Comment 2 Jay Dobies 2013-06-05 11:50:22 EDT
Mike - I'm not sure this is a Katello blocker; it was recharacterized as a client only bug.
Comment 3 Mike McCune 2013-06-18 18:14:43 EDT
cleared sat6-blocker
Comment 4 Brian Bouterse 2015-02-18 20:11:05 EST
Moved to https://pulp.plan.io/issues/193

Note You need to log in before you can comment on or make changes to this bug.