Bug 969147 - cobertura-2.1.1 is available
cobertura-2.1.1 is available
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: cobertura (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Mikolaj Izdebski
Fedora Extras Quality Assurance
: FutureFeature, Triaged
Depends On:
Blocks: 1197912
  Show dependency treegraph
 
Reported: 2013-05-30 14:51 EDT by Upstream Release Monitoring
Modified: 2015-03-24 07:31 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-03-24 07:31:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Upstream Release Monitoring 2013-05-30 14:51:43 EDT
Latest upstream release: 2.0
Current version in Fedora Rawhide: 1.9.4.1
URL: http://sourceforge.net/api/file/index/project-name/cobertura/mtime/desc/limit/100/rss

Please consult the package updates policy before you issue an update to a stable branch: https://fedoraproject.org/wiki/Updates_Policy

More information about the service that created this bug can be found at:
https://fedoraproject.org/wiki/Upstream_release_monitoring
Comment 1 Mikolaj Izdebski 2014-11-21 09:22:44 EST
Latest upstream version is 2.0.3.
It uses Maven to build, so it should be easier to maintain.

Upstream doesn't tag releases (uggh), but I found 2.0.3 commit: https://github.com/cobertura/cobertura/commit/6b7431daa0f463728b3888012feb959785d7edf4

Mat and Michal, can we update to 2.0.3?
Comment 2 Mikolaj Izdebski 2015-02-04 07:02:39 EST
2.0 was pushed to rawhide.

Despite micro version difference, 2.0.3 uses totally new build system and adds new dependencies, some of them like Jetty 6 are not available in Fedora. I'll work on updating to 2.0.3 later.
Comment 3 Michal Srb 2015-03-03 07:57:02 EST
cobertura-maven-plugin 2.7 requires cobertura 2.1.1
Comment 4 Mikolaj Izdebski 2015-03-24 07:31:46 EDT
Cobertura will be retired.

Note You need to log in before you can comment on or make changes to this bug.