Bug 969216 - activationkey add_subscription does not work in cli
activationkey add_subscription does not work in cli
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Hammer (Show other bugs)
6.0.1
Unspecified Unspecified
unspecified Severity low (vote)
: Unspecified
: --
Assigned To: Brad Buckingham
Og Maciel
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-30 18:36 EDT by Og Maciel
Modified: 2014-01-27 09:04 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-18 17:18:32 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Og Maciel 2013-05-30 18:36:48 EDT
Description of problem:

Using the CLI to add subscriptions to an activationkey gives a success message but it does not add anything.

Version-Release number of selected component (if applicable):

* apr-util-ldap-1.3.9-3.el6_0.1.x86_64
* candlepin-0.8.9-1.el6.noarch
* candlepin-cert-consumer-dell-pesc1425-02.lab.bos.redhat.com-1.0-1.noarch
* candlepin-selinux-0.8.9-1.el6.noarch
* candlepin-tomcat6-0.8.9-1.el6.noarch
* elasticsearch-0.19.9-7.el6.noarch
* foreman-1.1stable-31.3849429.el6.noarch
* foreman-postgresql-1.1stable-31.3849429.el6.noarch
* katello-1.4.2-1.git.489.5063ab2.el6.noarch
* katello-all-1.4.2-1.git.489.5063ab2.el6.noarch
* katello-candlepin-cert-key-pair-1.0-1.noarch
* katello-certs-tools-1.4.2-1.el6.noarch
* katello-cli-1.4.2-1.git.71.2a2d883.el6.noarch
* katello-cli-common-1.4.2-1.git.71.2a2d883.el6.noarch
* katello-common-1.4.2-1.git.489.5063ab2.el6.noarch
* katello-configure-1.4.3-1.git.44.48c2c61.el6.noarch
* katello-configure-foreman-1.4.3-1.git.44.48c2c61.el6.noarch
* katello-foreman-all-1.4.2-1.git.489.5063ab2.el6.noarch
* katello-glue-candlepin-1.4.2-1.git.489.5063ab2.el6.noarch
* katello-glue-elasticsearch-1.4.2-1.git.489.5063ab2.el6.noarch
* katello-glue-pulp-1.4.2-1.git.489.5063ab2.el6.noarch
* Katello-Katello-Installation-RegisterRHNClassic-1.1-3.noarch
* Katello-Katello-Sanity-ImportKeys-1.2-1.noarch
* katello-qpid-broker-key-pair-1.0-1.noarch
* katello-qpid-client-key-pair-1.0-1.noarch
* katello-repos-1.4.2-1.el6.noarch
* katello-selinux-1.4.3-1.git.3.ce8227b.el6.noarch
* openldap-2.4.23-31.el6.x86_64
* openldap-devel-2.4.23-31.el6.x86_64
* pulp-rpm-plugins-2.1.1-0.10.beta.el6.noarch
* pulp-selinux-2.1.1-0.10.beta.el6.noarch
* pulp-server-2.1.1-0.10.beta.el6.noarch
* python-ldap-2.3.10-1.el6.x86_64
* ruby193-rubygem-ldap_fluff-0.1.7-2.el6.noarch
* ruby193-rubygem-net-ldap-0.3.1-1.el6.noarch
* signo-0.0.9-1.el6.noarch
* signo-katello-0.0.9-1.el6.noarch

How reproducible:


Steps to Reproduce:

kk activation_key create --name ActivationKey1 --org 'Simple Org' --environment 'Dev Env'
kk activation_key update --name ActivationKey1 --org 'Simple Org' --environment 'Dev Env' --add_subcription 45678665367754556776646478675

Actual results:

Successfully updated activation key [ ActivationKey1 ]

kk activation_key info --name ActivationKey1
---------------------------------------------------------------------------------------------------------------------
                                                 Activation Key Info
---------------------------------------------------------------------------------------------------------------------

ID             : 39
Name           : ActivationKey1
Description:
    None
Usage Limit    : unlimited
Environment ID : 281
Content View   : [ PublishedComposite ]
Pools:
    [  ]

Expected results:


Additional info:
Comment 1 Og Maciel 2013-05-30 20:58:10 EDT
Looks like having RHEL content may make the difference. Using a different organization that only had custom content the same procedure above worked.
Comment 2 Og Maciel 2013-05-30 21:02:52 EDT
fwiw, I have not synced rhel content only enabled it

katello> org subscriptions --name 'Simple Org'
---------------------------------------------------------------------------------------------------------------------
                                            Organization's Subscriptions
---------------------------------------------------------------------------------------------------------------------

Subscription    : CloudForms Employee Subscription
Consumed        : 0
Contract Number : XXXXXXX
SLA             : 
ID              : ***********************************
Limits:
    [  ]
Start Date      : 2012/11/20 05:00:00
End Date        : 2022/01/01 04:59:59


Subscription    : Red Hat Employee Subscription
Consumed        : 0
Contract Number : XXXXXX
SLA             : 
ID              : ************************************
Limits:
    [ Sockets: 128 ]
Start Date      : 2011/10/08 04:00:00
End Date        : 2022/01/01 04:59:59


Subscription    : Chrome
Consumed        : 0
Contract Number : None
SLA             : 
ID              : 8a90add63ef6a84c013ef6d300ba005c
Limits:
    [  ]
Start Date      : 2013/05/30 00:00:00
End Date        : 2043/05/23 00:00:00


Subscription    : Agent
Consumed        : 0
Contract Number : None
SLA             : 
ID              : 8a90add63ef6a84c013ef6d898f10061
Limits:
    [  ]
Start Date      : 2013/05/30 00:00:00
End Date        : 2043/05/23 00:00:00
Comment 3 Og Maciel 2013-05-30 22:00:38 EDT
After some more debugging by DEV we are now suspecting that organizations with names that have spaces in them may be the culprit. More to follow.
Comment 4 Brad Buckingham 2013-05-31 10:44:56 EDT
katello pull request:
https://github.com/Katello/katello/pull/2409
Comment 6 Brad Buckingham 2013-06-06 17:58:53 EDT
Mass move to ON_QA
Comment 7 Og Maciel 2013-06-07 18:25:25 EDT
Verified:

* apr-util-ldap-1.3.9-3.el6_0.1.x86_64
* candlepin-0.8.9-1.el6_4.noarch
* candlepin-scl-1-5.el6_4.noarch
* candlepin-scl-quartz-2.1.5-5.el6_4.noarch
* candlepin-scl-rhino-1.7R3-1.el6_4.noarch
* candlepin-scl-runtime-1-5.el6_4.noarch
* candlepin-selinux-0.8.9-1.el6_4.noarch
* candlepin-tomcat6-0.8.9-1.el6_4.noarch
* elasticsearch-0.19.9-8.el6sat.noarch
* foreman-1.1.10005-1.noarch
* foreman-compute-1.1.10005-1.noarch
* foreman-installer-puppet-concat-0-2.d776701.git.0.21ef926.el6sat.noarch
* foreman-installer-puppet-dhcp-0-5.3a4a13c.el6sat.noarch
* foreman-installer-puppet-dns-0-7.fcae203.el6sat.noarch
* foreman-installer-puppet-foreman-0-6.568c5c4.el6sat.noarch
* foreman-installer-puppet-foreman_proxy-0-8.bd1e35d.el6sat.noarch
* foreman-installer-puppet-puppet-0-3.ab46748.el6sat.noarch
* foreman-installer-puppet-tftp-0-5.ea6c5e5.el6sat.noarch
* foreman-installer-puppet-xinetd-0-50a267b8.git.0.44aca6a.el6sat.noarch
* foreman-libvirt-1.1.10005-1.noarch
* foreman-postgresql-1.1.10005-1.noarch
* foreman-proxy-1.1.10003-1.el6sat.noarch
* foreman-proxy-installer-1.0.1-8.f5ae2cd.el6sat.noarch
* katello-1.4.2-11.el6sat.noarch
* katello-all-1.4.2-11.el6sat.noarch
* katello-candlepin-cert-key-pair-1.0-1.noarch
* katello-certs-tools-1.4.2-2.el6sat.noarch
* katello-cli-1.4.2-7.el6sat.noarch
* katello-cli-common-1.4.2-7.el6sat.noarch
* katello-common-1.4.2-11.el6sat.noarch
* katello-configure-1.4.3-14.el6sat.noarch
* katello-configure-foreman-1.4.3-14.el6sat.noarch
* katello-foreman-all-1.4.2-11.el6sat.noarch
* katello-glue-candlepin-1.4.2-11.el6sat.noarch
* katello-glue-elasticsearch-1.4.2-11.el6sat.noarch
* katello-glue-pulp-1.4.2-11.el6sat.noarch
* katello-qpid-broker-key-pair-1.0-1.noarch
* katello-qpid-client-key-pair-1.0-1.noarch
* katello-selinux-1.4.3-3.el6sat.noarch
* openldap-2.4.23-31.el6.x86_64
* openldap-devel-2.4.23-31.el6.x86_64
* pulp-rpm-plugins-2.1.1-1.el6sat.noarch
* pulp-selinux-2.1.1-1.el6sat.noarch
* pulp-server-2.1.1-1.el6sat.noarch
* python-ldap-2.3.10-1.el6.x86_64
* ruby193-rubygem-ldap_fluff-0.2.2-1.el6sat.noarch
* ruby193-rubygem-net-ldap-0.3.1-2.el6sat.noarch
* signo-0.0.16-1.el6sat.noarch
* signo-katello-0.0.16-1.el6sat.noarch
Comment 8 Mike McCune 2013-07-18 17:18:32 EDT
mass move to CLOSED:CURRENTRELEASE since MDP1 has been released.

Note You need to log in before you can comment on or make changes to this bug.