Bug 969236 - Beaker 1.0 Unscheduled query failing since upgrade to 4.4
Beaker 1.0 Unscheduled query failing since upgrade to 4.4
Status: CLOSED UPSTREAM
Product: Bugzilla
Classification: Community
Component: Performance (Show other bugs)
4.4
Unspecified Unspecified
unspecified Severity unspecified (vote)
: ---
: ---
Assigned To: PnT DevOps Devs
tools-bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-30 21:56 EDT by Nick Coghlan
Modified: 2013-06-23 21:53 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-04 03:10:30 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Mozilla Foundation 879055 None None None Never

  None (edit)
Description Nick Coghlan 2013-05-30 21:56:57 EDT
Description of problem:

My saved "Beaker 1.0 Unscheduled" query consistently times out since the upgrade to Bugzilla 4.4


Version-Release number of selected component (if applicable):

bugzilla-redhat-4.4-??

How reproducible:

Always

Steps to Reproduce:
1. Click this link https://bugzilla.redhat.com/query.cgi?bug_status=NEW&bug_status=ASSIGNED&bug_status=POST&columnlist=estimated_time%2Cpriority%2Cassigned_to%2Cbug_status%2Cresolution%2Cshort_desc%2Cchangeddate&f1=flagtypes.name&f2=cf_devel_whiteboard&o1=anywordssubstr&o2=isnull&order=bug_status%2Cpriority%2Cassigned_to%2Cbug_id&product=Beaker&query_format=advanced&query_type=advanced&v1=beaker-1.0%2B%2Cbeaker-1.0%3F&known_name=Beaker%201.0%20Unscheduled
2. Click "Search"
3.

Actual results:

Query times out.

Expected results:

Displays the list of Beaker bugs flagged for (possible) inclusion in 1.0, but not yet implemented or assigned to a development sprint.

Additional info:

This same query used to work in Bugzilla 4.2
Comment 2 Nick Coghlan 2013-06-04 21:47:53 EDT
Thanks, the updated search did the trick. It would be nice if Bugzilla reported an error for searches like my old one rather than timing out, though.
Comment 3 Simon Green 2013-06-04 23:11:39 EDT
(In reply to wangjing from comment #1)
> hi,
> on current version, in Custom Search section, we can't search for more than
> one flags in one line, we should set two conditions seperately, so the
> former URL will not work, which the conditions were set as 'Flags' 'contains
> all of the strings' 'qa_ack+ 6.5.0',  they put the two flags together in one.

Jing: That is not what is the problem. The problem in bug 966456 is that you get no results. In this bug, the problem is that it times out.

Nick: This is a known problem and has been fixed upstream. We will inherit the change on the next release.

Note You need to log in before you can comment on or make changes to this bug.