Bug 969253 - can't start foreman-proxy
can't start foreman-proxy
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Provisioning (Show other bugs)
Nightly
Unspecified Unspecified
unspecified Severity high (vote)
: Unspecified
: --
Assigned To: Ohad Levy
Og Maciel
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-30 23:00 EDT by Mike McCune
Modified: 2014-01-27 08:46 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-18 17:19:11 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mike McCune 2013-05-30 23:00:29 EDT
After configuration you can't seem to start foreman-proxy with the service script:

# /sbin/service foreman-proxy start
Starting foreman-proxy: /usr/share/foreman-proxy/lib/smart_proxy.rb:1: warning: already initialized constant APP_ROOT
/opt/rh/ruby193/root/usr/share/rubygems/rubygems/dependency.rb:247:in `to_specs': Could not find rack-protection (~> 1.3) amongst [Ascii85-1.0.2, actionmailer-3.2.8, actionpack-3.2.8, activemodel-3.2.8, activerecord-3.2.8, activeresource-3.2.8, activesupport-3.2.8, acts_as_reportable-1.1.1, ancestry-1.3.0, anemone-0.7.2, apipie-params-0.0.2, apipie-rails-0.0.18, arel-3.0.2, audited-3.0.0, audited-activerecord-3.0.0, bigdecimal-1.1.0, builder-3.0.0, bundler-1.1.4, bundler_ext-0.3.0, chunky_png-1.2.0, coffee-rails-3.2.2, coffee-script-2.2.0, coffee-script-source-1.3.3, color-1.4.1, compass-0.12.2, compass-960-plugin-0.10.4, compass-rails-1.0.3, daemons-1.1.4, deface-0.7.2, delayed_job-3.0.2, delayed_job_active_record-0.3.3, diff-lcs-1.1.3, dynflow-0.1.0, erubis-2.7.0, eventmachine-0.12.10, execjs-1.4.0, fast_gettext-0.5.10, fastercsv-1.5.4, foreman-katello-engine-0.0.8, foreman_api-0.1.3, fssm-0.2.7, gettext-2.3.7, gettext_i18n_rails-0.9.4, gettext_i18n_rails_js-0.0.8, haml-3.1.6, haml-rails-0.3.4, hashr-0.0.22, hike-1.2.1, hooks-0.2.2, hpricot-0.8.6, i18n-0.6.0, i18n_data-0.2.7, io-console-0.3, journey-1.0.4, jquery-rails-2.0.2, jquery-ui-rails-4.0.2, json-1.5.5, katello-foreman-engine-0.0.3, katello_api-0.0.3, ldap_fluff-0.1.7, levenshtein-0.2.2, little-plugger-1.1.3, locale-2.0.8, logging-1.8.1, mail-2.4.4, mime-types-1.19, multi_json-1.3.6, net-http-persistent-2.7, net-ldap-0.2.2, nokogiri-1.5.6, oauth-0.4.7, pdf-reader-1.1.1, pdf-writer-1.1.8, pg-0.12.2, po_to_json-0.0.7, polyglot-0.3.3, prawn-1.0.0.rc1, rabl-0.7.6, rack-1.4.1, rack-cache-1.2, rack-openid-1.3.1, rack-protection-1.2.0, rack-ssl-1.3.2, rack-test-0.6.1, rails-3.2.8, rails_warden-0.5.2, railties-3.2.8, rake-0.9.2.2, rdoc-3.12, ref-1.0.0, regin-0.3.8, rest-client-1.6.1, rkerberos-0.1.1, robotex-1.0.0, ruby-openid-2.2.3, ruby-progressbar-1.0.2, ruby-rc4-0.1.5, ruby2ruby-2.0.1, ruby_parser-3.1.1, runcible-0.4.8, ruport-1.7.0, safemode-1.2.0, sass-3.1.20, sass-rails-3.2.5, scoped_search-2.5.1, sexp_processor-4.1.3, simple-navigation-3.3.4, sinatra-1.3.6, sprockets-2.4.5, therubyracer-0.11.0beta8, thin-1.3.1, thor-0.15.4, tilt-1.3.3, tire-0.3.13.pre, transaction-simple-1.4.0.2, treetop-1.4.10, ttfunk-1.0.3, twitter-bootstrap-rails-2.2.6, tzinfo-0.3.33, uglifier-1.2.6, ui_alchemy-rails-1.0.10, uuidtools-2.1.3, warden-1.0.3, will_paginate-3.0.2] (Gem::LoadError)
	from /opt/rh/ruby193/root/usr/share/rubygems/rubygems/specification.rb:777:in `block in activate_dependencies'
	from /opt/rh/ruby193/root/usr/share/rubygems/rubygems/specification.rb:766:in `each'
	from /opt/rh/ruby193/root/usr/share/rubygems/rubygems/specification.rb:766:in `activate_dependencies'
	from /opt/rh/ruby193/root/usr/share/rubygems/rubygems/specification.rb:750:in `activate'
	from /opt/rh/ruby193/root/usr/share/rubygems/rubygems.rb:212:in `rescue in try_activate'
	from /opt/rh/ruby193/root/usr/share/rubygems/rubygems.rb:209:in `try_activate'
	from /opt/rh/ruby193/root/usr/share/rubygems/rubygems/custom_require.rb:59:in `rescue in require'
	from /opt/rh/ruby193/root/usr/share/rubygems/rubygems/custom_require.rb:35:in `require'
	from /usr/share/foreman-proxy/lib/sinatra-patch.rb:1:in `<top (required)>'
Comment 1 Mike McCune 2013-05-30 23:01:38 EDT
we are using:

ruby193-rubygem-rack-protection-1.2.0-11.el6_4.noarch
Comment 2 Mike McCune 2013-05-30 23:07:12 EDT
looks like the latest sinatra did this:

/opt/rh/ruby193/root/usr/share/gems/specifications/sinatra-1.3.6.gemspec:      s.add_runtime_dependency(%q<rack-protection>, ["~> 1.3"])
/opt/rh/ruby193/root/usr/share/gems/specifications/sinatra-1.3.6.gemspec:      s.add_dependency(%q<rack-protection>, ["~> 1.3"])
/opt/rh/ruby193/root/usr/share/gems/specifications/sinatra-1.3.6.gemspec:    s.add_dependency(%q<rack-protection>, ["~> 1.3"])
Comment 3 Mike McCune 2013-05-30 23:13:02 EDT
downgrade to:

ruby193-rubygem-sinatra-1.3.2-17

works around the issue:

http://download.devel.redhat.com/brewroot/packages/ruby193-rubygem-sinatra/1.3.2/17.el6ost/noarch/ruby193-rubygem-sinatra-1.3.2-17.el6ost.noarch.rpm
Comment 4 Ohad Levy 2013-05-31 01:52:36 EDT
1.3.2 has another bug which affect the dhcp functionality of the proxy, see https://github.com/sinatra/sinatra/issues/452 for details
Comment 6 Mike McCune 2013-06-03 13:32:17 EDT
This should have got moved to ON_QA
Comment 7 Og Maciel 2013-06-03 22:51:26 EDT
[root@qeblade35 ~]# service foreman-proxy status
foreman-proxy (pid  19193) is running...
[root@qeblade35 ~]# service foreman-proxy stop
Stopping foreman-proxy:                                    [  OK  ]
[root@qeblade35 ~]# service foreman-proxy status
foreman-proxy is stopped
[root@qeblade35 ~]# service foreman-proxy start
Starting foreman-proxy: WARNING: Missing SSL setup, working in clear text mode !

        from /usr/share/foreman-proxy/lib/smart_proxy.rb:51:in `<class:SmartProxy>'
                                                           [  OK  ]
[root@qeblade35 ~]# service foreman-proxy status
foreman-proxy (pid  27859) is running...
[root@qeblade35 ~]# service foreman-proxy restart
Stopping foreman-proxy:                                    [  OK  ]
Starting foreman-proxy: WARNING: Missing SSL setup, working in clear text mode !

        from /usr/share/foreman-proxy/lib/smart_proxy.rb:51:in `<class:SmartProxy>'
                                                           [  OK  ]
[root@qeblade35 ~]# service foreman-proxy status
foreman-proxy (pid  27902) is running...
Comment 9 Mike McCune 2013-07-18 17:19:11 EDT
mass move to CLOSED:CURRENTRELEASE since MDP1 has been released.

Note You need to log in before you can comment on or make changes to this bug.