Bug 969274 - SELinux is preventing /opt/teamviewer8/tv_bin/teamviewerd from 'connectto' accesses on the unix_stream_socket @/tmp/.X11-unix/X0.
SELinux is preventing /opt/teamviewer8/tv_bin/teamviewerd from 'connectto' ac...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
18
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:6a23116a26c00082442d31c4ec3...
:
: 969275 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-31 02:26 EDT by Moez Roy
Modified: 2013-10-25 09:14 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-25 09:14:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Moez Roy 2013-05-31 02:26:38 EDT
Description of problem:
SELinux is preventing /opt/teamviewer8/tv_bin/teamviewerd from 'connectto' accesses on the unix_stream_socket @/tmp/.X11-unix/X0.

*****  Plugin catchall (100. confidence) suggests  ***************************

If you believe that teamviewerd should be allowed connectto access on the X0 unix_stream_socket by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# grep teamviewerd /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                system_u:system_r:init_t:s0
Target Context                system_u:system_r:xserver_t:s0-s0:c0.c1023
Target Objects                @/tmp/.X11-unix/X0 [ unix_stream_socket ]
Source                        teamviewerd
Source Path                   /opt/teamviewer8/tv_bin/teamviewerd
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           teamviewer-8.0.17147-1.i686
Target RPM Packages           
Policy RPM                    selinux-policy-3.11.1-97.fc18.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Host Name                     (removed)
Platform                      Linux (removed) 3.9.4-200.fc18.x86_64 #1 SMP Fri
                              May 24 20:10:49 UTC 2013 x86_64 x86_64
Alert Count                   1
First Seen                    2013-05-30 23:25:29 PDT
Last Seen                     2013-05-30 23:25:29 PDT
Local ID                      b4f7768f-2366-45a3-992d-21696384d77a

Raw Audit Messages
type=AVC msg=audit(1369981529.825:336): avc:  denied  { connectto } for  pid=1354 comm="teamviewerd" path=002F746D702F2E5831312D756E69782F5830 scontext=system_u:system_r:init_t:s0 tcontext=system_u:system_r:xserver_t:s0-s0:c0.c1023 tclass=unix_stream_socket


type=SYSCALL msg=audit(1369981529.825:336): arch=i386 syscall=getuid success=no exit=EACCES a0=3 a1=f69febd0 a2=f75c2000 a3=0 items=0 ppid=1 pid=1354 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=1000 egid=0 sgid=0 fsgid=0 ses=4294967295 tty=(none) comm=teamviewerd exe=/opt/teamviewer8/tv_bin/teamviewerd subj=system_u:system_r:init_t:s0 key=(null)

Hash: teamviewerd,init_t,xserver_t,unix_stream_socket,connectto

audit2allow

#============= init_t ==============
allow init_t xserver_t:unix_stream_socket connectto;

audit2allow -R
require {
	type init_t;
}

#============= init_t ==============
xserver_dontaudit_stream_connect(init_t)


Additional info:
reporter:       libreport-2.1.4
hashmarkername: setroubleshoot
kernel:         3.9.4-200.fc18.x86_64
type:           libreport
Comment 1 Daniel Walsh 2013-05-31 10:58:18 EDT
*** Bug 969275 has been marked as a duplicate of this bug. ***
Comment 2 Moez Roy 2013-06-02 01:52:45 EDT
this computer uses intel graphics
Comment 3 Moez Roy 2013-06-02 01:54:44 EDT
(In reply to quickbooks.office from comment #2)
> this computer uses intel graphics

ignore previous post...I posted reply on the wrong bug...sorry
Comment 4 Daniel Walsh 2013-06-08 06:30:39 EDT
You need to write policy for teamviewerd
Comment 5 Miroslav Grepl 2013-06-11 10:17:21 EDT
There is another bug where I wrote steps how to do it.

Note You need to log in before you can comment on or make changes to this bug.