Bug 969299 - felix-parent has many unnecessary Requires
felix-parent has many unnecessary Requires
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: felix-parent (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Mikolaj Izdebski
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-31 03:08 EDT by Marek Goldmann
Modified: 2013-05-31 06:40 EDT (History)
2 users (show)

See Also:
Fixed In Version: 1.2.1-12
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-31 06:40:13 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch (5.45 KB, patch)
2013-05-31 05:19 EDT, Marek Goldmann
no flags Details | Diff

  None (edit)
Description Marek Goldmann 2013-05-31 03:08:48 EDT
Description of problem:

The felix-parent package has many Requires which should be removed. These requires should be moved to actual packages. Currently if the -parent is pulled by some package at runtime it installs many unnecessary build-time dependencies. A classpath issue with easymock2 (pulled in by felix) and easymock3 (actual requires) hit me because of this when I was packaging a new project for Fedora.

Please take a look at jboss-parent example, this was cleaned some time ago: 

http://pkgs.fedoraproject.org/cgit/jboss-parent.git/tree/jboss-parent.spec

Version-Release number of selected component (if applicable):

felix-parent-1.2.1-11
Comment 1 Marek Goldmann 2013-05-31 05:19:23 EDT
Created attachment 755209 [details]
Patch

Attaching a patch that fixes the issue and cleanups the spec file.
Comment 2 Mikolaj Izdebski 2013-05-31 06:21:47 EDT
Fixed in felix-parent-1.2.1-12
Comment 3 Mikolaj Izdebski 2013-05-31 06:40:13 EDT
I believe that this bug is fixed in felix-parent-1.2.1-12,
which is available in Fedora Rawhide, so I am closing this bug now.

The build containing the fix can be found at Koji:
http://koji.fedoraproject.org/koji/buildinfo?buildID=423149

Note You need to log in before you can comment on or make changes to this bug.