Bug 96934 - (IDE PIIX)Boot fine ONLY with Boot Diskette, Otherwise, it hangs?
(IDE PIIX)Boot fine ONLY with Boot Diskette, Otherwise, it hangs?
Status: CLOSED CANTFIX
Product: Red Hat Linux
Classification: Retired
Component: grub (Show other bugs)
8.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Peter Jones
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-06-06 14:14 EDT by Need Real Name
Modified: 2007-04-18 12:54 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-18 12:33:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2003-06-06 14:14:46 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0)

Description of problem:
I had RH8 installed on a DELL LS400 laptop. Once installed, it boots fine ONLY 
when I use the Boot Diskette.  Otherwise, I get the following errors and then 
it hangs: 
===========================================
PIIX4: not 100% native mode: will probe irqs later 
ide0: BM-DMA at 0xfcd0-0xfcd7, BIOS settings: hda:pio, hdb:pio 
ide1: BM-DMA at 0xfcd8-0xfcdf, BIOS settings: hdc:pio, hdd:pio 
hda: IBM-DBCA-206480, ATA DISK drive 
hda: set_drive_speed_status: Status=0xd0 {Busy} 
blk: queue c03a5260, I/O limit 4095Mb (mask 0xffffffff) 
ide0 at 0x1f0-0x1f7,0x3f6 on irq 14 
hda: attached ide-disk driver. 
hda: irq timeout: Status=0xd0 {Busy} 
Partition check: 
hda: DMA disabled 
hda: Drive not ready for command 
...etc...
Kernel Panic...etc.
============================================


Version-Release number of selected component (if applicable):
kernel-2.4.18-14

How reproducible:
Always

Steps to Reproduce:
1. Boot without using the Boot Diskette
2.
3.
    

Actual Results:  Hangs at boot

Expected Results:  Boot thru to Login Screen

Additional info:
Comment 1 Alan Cox 2003-06-08 07:56:16 EDT
Does the problem occur with the latest errata kernels too ?
Comment 2 Need Real Name 2003-06-09 13:33:48 EDT
I did upgrade thru up2date to 2.4.20-18.14 kernel and stsill get into the same 
error.
Comment 3 Alan Cox 2003-06-09 13:49:48 EDT
Thanks. I don't think I'm any nearer to figuring this specific laptop funny out
but it helps to know its not fixed 8(
Comment 4 Need Real Name 2003-06-09 15:29:11 EDT
Does the following help or can I give you some other info.?
Laptop:  Latitude LS400
Memory:  256MB
Hard Drive:  Model:  IBM-DBCA-206480 (6.5G)/ DJSA-210 (6G)
I just wonder what it takes to "borrow or copy" the settings from the boot 
diskette to the /boot partition or whenever to make it boot normally w/o the 
boot diskette.

Comment 5 Alan Cox 2003-06-09 20:37:37 EDT
I don't think it settings specifically. The only real differences for the boot
disk kernel is probably APM. You could test this by trying to boot off hard disk
and adding the options

apm=off noapic

at the grub boot menu

However I am mostly baffled I'm afraid
Comment 6 Need Real Name 2003-06-10 14:42:06 EDT
I've not tried the "apm=off noapic" yet.  However, I got it boot properly by 
changing the boot loader from grub to lilo.  I verify it by using the exact 
same installation options but swap it between grub and lilo.  I have installed 
w/ lilo twice since then, it boots gracefully on each ocassion.  Kernel is 
2.4.18-14 @ installation and I have already updated it to 2.4.20-18.xx and have 
not encountered any problem so far.

Any idea why this may happen?  I would love to use grub because I would like to 
try to do some dual/ multi boot very soon and grub gives me more flexibility 
down the road.

Comment 7 Alan Cox 2003-06-10 14:58:45 EDT
So it seems to be grub not kernel triggered. Thats strange but not unique.
Transferring the bug to the grub folks to think about
Comment 8 Jeremy Katz 2003-06-10 16:00:50 EDT
Does it work with the grub 0.93 shipped in Red Hat Linux 9?
Comment 9 Need Real Name 2003-06-10 21:42:02 EDT
I did install RH9 one time and it had the same boot problem.  
Comment 10 Jeremy Katz 2003-06-10 22:16:36 EDT
Hrmm... haven't heard anything like that.  Will try to poke around some.  Alan's
suggestion of kernel command line parameters would be interesting to know the
outcome of.
Comment 11 Bill Nottingham 2006-08-07 15:08:29 EDT
Red Hat Linux is no longer supported by Red Hat, Inc. If you are still
running Red Hat Linux, you are strongly advised to upgrade to a
current Fedora Core release or Red Hat Enterprise Linux or comparable.
Some information on which option may be right for you is available at
http://www.redhat.com/rhel/migrate/redhatlinux/.

Red Hat apologizes that these issues have not been resolved yet. We do
want to make sure that no important bugs slip through the cracks.
Please check if this issue is still present in a current Fedora Core
release. If so, please change the product and version to match, and
check the box indicating that the requested information has been
provided. Note that any bug still open against Red Hat Linux on will be
closed as 'CANTFIX' on September 30, 2006. Thanks again for your help.
Comment 12 Bill Nottingham 2006-10-18 12:33:41 EDT
Red Hat Linux is no longer supported by Red Hat, Inc. If you are still
running Red Hat Linux, you are strongly advised to upgrade to a
current Fedora Core release or Red Hat Enterprise Linux or comparable.
Some information on which option may be right for you is available at
http://www.redhat.com/rhel/migrate/redhatlinux/.

Closing as CANTFIX.

Note You need to log in before you can comment on or make changes to this bug.