Bug 969345 - auditd.service:17]: Unknown lvalue 'RefuseManualStop'
auditd.service:17]: Unknown lvalue 'RefuseManualStop'
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: audit (Show other bugs)
18
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Steve Grubb
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-31 05:25 EDT by Harald Reindl
Modified: 2013-06-11 05:00 EDT (History)
1 user (show)

See Also:
Fixed In Version: audit-2.3.1-2.fc18
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-11 05:00:26 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Harald Reindl 2013-05-31 05:25:11 EDT
why do you maintainers not look in /var/log/messages on the machines where you hopefully try units before submit them to a fedora-build? having *one* such a systemd-unit results in flooding the logs while a yum-dist-upgrade caused by a lot of systemd-reloads


[root@srv-rhsoft:~]$ rpm -q audit
audit-2.3.1-1.fc18.x86_64

[root@srv-rhsoft:~]$ rpm -q systemd
systemd-201-2.fc18.7.x86_64

May 31 11:20:23 srv-rhsoft systemd[1]: [/usr/lib/systemd/system/auditd.service:17] Unknown lvalue 'RefuseManualStop' in section 'Service'
May 31 11:20:23 srv-rhsoft systemd[1]: logged here: 'Unknown lvalue 'RefuseManualStop' in section 'Service'': 1
__________________________________

[root@srv-rhsoft:~]$ systemctl daemon-reload 
[root@srv-rhsoft:~]$ cat messages 
May 31 11:20:23 srv-rhsoft systemd[1]: [/usr/lib/systemd/system/auditd.service:17] Unknown lvalue 'RefuseManualStop' in section 'Service'
May 31 11:20:23 srv-rhsoft systemd[1]: logged here: 'Unknown lvalue 'RefuseManualStop' in section 'Service'': 1
[root@srv-rhsoft:~]$ systemctl daemon-reload 
[root@srv-rhsoft:~]$ cat messages 
May 31 11:20:23 srv-rhsoft systemd[1]: [/usr/lib/systemd/system/auditd.service:17] Unknown lvalue 'RefuseManualStop' in section 'Service'
May 31 11:20:23 srv-rhsoft systemd[1]: logged here: 'Unknown lvalue 'RefuseManualStop' in section 'Service'': 1
May 31 11:21:28 srv-rhsoft systemd[1]: [/usr/lib/systemd/system/auditd.service:17] Unknown lvalue 'RefuseManualStop' in section 'Service'
May 31 11:21:28 srv-rhsoft systemd[1]: logged here: 'Unknown lvalue 'RefuseManualStop' in section 'Service'': 1
Comment 1 Steve Grubb 2013-05-31 10:30:44 EDT
Thanks for reporting this. I'll push out a corrected package shortly. Turns out fixing this problem leads to a bunch more.
Comment 2 Steve Grubb 2013-05-31 13:05:19 EDT
Pushed new build into build system to fix this issue.
Comment 3 Fedora Update System 2013-05-31 13:06:10 EDT
audit-2.3.1-2.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/FEDORA-2013-9693/audit-2.3.1-2.fc18
Comment 4 Fedora Update System 2013-05-31 22:29:36 EDT
Package audit-2.3.1-2.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing audit-2.3.1-2.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-9693/audit-2.3.1-2.fc18
then log in and leave karma (feedback).
Comment 5 Fedora Update System 2013-06-11 05:00:26 EDT
audit-2.3.1-2.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.