Bug 969362 - The error info need further implement while check disk's block I/O throttling info for an non-existent domain
The error info need further implement while check disk's block I/O throttling...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: libvirt (Show other bugs)
7.0
x86_64 Linux
low Severity low
: rc
: ---
Assigned To: Martin Kletzander
Virtualization Bugs
virsh cmd
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-31 05:58 EDT by zhenfeng wang
Modified: 2014-06-17 20:50 EDT (History)
6 users (show)

See Also:
Fixed In Version: libvirt-1.0.6-1.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-13 08:50:04 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description zhenfeng wang 2013-05-31 05:58:25 EDT
Description of problem:
The error info need further implement while check disk's block I/O throttling info for an non-existent domain

Version-Release number of selected component (if applicable):
libvirt-1.0.5-2.el7.x86_64
kernel-3.9.0-0.55.el7.x86_64
qemu-kvm-1.4.0-4.el7.x86_64
How reproducible:
100%

Steps
1  check  disk's block I/O throttling info for an non-existent domain
# virsh blkdeviotune a vda

Actual results:
# virsh blkdeviotune a vda
error: failed to get domain 'a'
error: invalid domain pointer in virDomainFree

Expected results:
should get the error info like this:
# virsh blkdeviotune a vda
error: failed to get domain 'a'
error: Domain not found: no domain with matching name 'a'
Comment 1 Peter Krempa 2013-05-31 06:04:36 EDT
Fixed upstream by:

commit 0a24028f11edda53d46591592f7dd5899a133a39
Author: Martin Kletzander <mkletzan@redhat.com>
Date:   Thu May 23 12:24:08 2013 +0200

    virsh: Fix virDomainFree for NULL domain in blkdeviotune

v1.0.5-350-g0a24028
Comment 3 zhenfeng wang 2013-06-05 06:35:46 EDT
Verified it on libvirt-1.0.6-1.el7.x86_64

steps

# virsh blkdeviotune afasdfjls vda
error: failed to get domain 'afasdfjls'
error: Domain not found: no domain with matching name 'afasdfjls'

# virsh blkdeviotune afasdfj###ls vda
error: failed to get domain 'afasdfj###ls'
error: Domain not found: no domain with matching name 'afasdfj###ls'
# virsh blkdeviotune 123456 vda
error: failed to get domain '123456'
error: Domain not found: no domain with matching name '123456'

since we could get the expect result,so mark this bug verified
Comment 4 hyao@redhat.com 2013-06-28 01:50:22 EDT
The bug doesn't reproduce with the latest package on rhel7.0: 
# rpm -qa libvirt qemu-kvm
qemu-kvm-1.5.0-2.el7.x86_64
libvirt-1.0.6-1.el7.x86_64
Comment 5 Ludek Smid 2014-06-13 08:50:04 EDT
This request was resolved in Red Hat Enterprise Linux 7.0.

Contact your manager or support representative in case you have further questions about the request.

Note You need to log in before you can comment on or make changes to this bug.