Bug 969389 - anaconda-tb file present after installation - IOError: [Errno 5] Input/output error
anaconda-tb file present after installation - IOError: [Errno 5] Input/output...
Status: CLOSED WORKSFORME
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: anaconda (Show other bugs)
7.0
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Vratislav Podzimek
Release Test Team
:
: 1014971 (view as bug list)
Depends On:
Blocks: 782468
  Show dependency treegraph
 
Reported: 2013-05-31 06:52 EDT by Richard Marko
Modified: 2016-01-31 21:22 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-03 08:05:11 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 2 David Cantrell 2013-08-02 13:09:48 EDT
Traceback (most recent call first):
  File "/usr/lib64/python2.7/atexit.py", line 29, in _run_exitfuncs
    print >> sys.stderr, "Error in atexit._run_exitfuncs:"
IOError: [Errno 5] Input/output error



/usr/lib64/python2.7/atexit.py is owned by the python package, not anaconda.  Reassigning.
Comment 3 Bohuslav "Slavek" Kabrda 2013-08-08 06:34:28 EDT
I'm unable to reproduce this with current composes of rhel 7. Richard, can you still see this issue?

It's quite hard to judge from the traceback file, but:
1) David, the fact that python package owns that file doesn't really mean that the problem is in the package. Do you have any more reasons why to believe that error is in Python?
2) From my experience, this errno can be raised when you have parent Python process that spawns child processes via subprocess module, but then the parent process and its terminal are closed => child processes have no terminal to write to. If this is the case, the problem could be pretty much anywhere where anaconda spawns subprocesses...
Comment 4 David Shea 2013-10-04 09:18:25 EDT
*** Bug 1014971 has been marked as a duplicate of this bug. ***
Comment 5 David Shea 2013-10-04 09:20:41 EDT
In reply to the comment on bug 1014971, anaconda reboots the system during the atexit calls, so yes, the terminal has been closed. That's not a good reason for atexit failing.
Comment 6 Bohuslav "Slavek" Kabrda 2013-10-07 06:36:49 EDT
(In reply to David Shea from comment #5)
> In reply to the comment on bug 1014971, anaconda reboots the system during
> the atexit calls, so yes, the terminal has been closed. That's not a good
> reason for atexit failing.

Actually, it's a perfect reason to fail. Python can't check whether the terminal is open before every print. So I guess this is Anaconda's problem and should be reassigned back to Anaconda, do you agree?
Comment 7 Bohuslav "Slavek" Kabrda 2013-11-05 06:13:14 EST
Reassigning to Anaconda. As noted in the previous comment, Python can't check whether the terminal is open before every print. This should be checked in Anaconda.
Comment 8 Vratislav Podzimek 2013-11-06 10:53:34 EST
Is this bug still reproducible with any of the recent composes? And if so, how? I cannot find any way to do so.
Comment 9 Richard Marko 2013-12-03 08:05:11 EST
No. If I'll encounter it again I'll reopen this bug.

Note You need to log in before you can comment on or make changes to this bug.