Bug 969391 - RHEL 5 boost not compatible with DTS gcc
RHEL 5 boost not compatible with DTS gcc
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: boost (Show other bugs)
5.8
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Petr Machata
qe-baseos-tools
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-31 07:00 EDT by Petr Machata
Modified: 2015-05-04 21:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-13 14:46:18 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Fix for this issue (1.53 KB, patch)
2013-05-31 07:00 EDT, Petr Machata
no flags Details | Diff

  None (edit)
Description Petr Machata 2013-05-31 07:00:48 EDT
Created attachment 755232 [details]
Fix for this issue

Description of problem:
Boost as shipped with RHEL 5 fails to detect threading support in recent GCC's (such as those shipped with DTS).  See this for more details:
  https://svn.boost.org/trac/boost/ticket/6165
Bug 969183 has a patch that can be used verbatim for this version of Boost as well.

There are also other small problems that are fixed by the attached patch.

Version-Release number of selected component (if applicable):
boost-1.33.1-16.el5

How reproducible:
Always.

Steps to Reproduce:
- For the threading issue, use the same reproducer as bug 969183.
- Users of Boost.Wave would notice a problem with missing include and a "changes meaning of" error message by GCC.
Comment 1 RHEL Product and Program Management 2013-05-31 07:21:26 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unable to address this
request at this time.

Red Hat invites you to ask your support representative to
propose this request, if appropriate, in the next release of
Red Hat Enterprise Linux.
Comment 3 Petr Machata 2013-11-13 14:46:18 EST
This Bugzilla has been reviewed by Red Hat and is not planned on being
addressed in Red Hat Enterprise Linux 5, and therefore will be closed.
If this bug is critical to production systems, please contact your Red
Hat support representative and provide sufficient business
justification.

Note You need to log in before you can comment on or make changes to this bug.