Bug 969447 - Run Once -> Run Stateless & Paused - event msg look odd
Run Once -> Run Stateless & Paused - event msg look odd
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
3.3.0
Unspecified Unspecified
low Severity low
: ovirt-3.6.0-rc
: 3.6.0
Assigned To: Arik
sefi litmanovich
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-31 08:42 EDT by Jiri Belka
Modified: 2016-04-19 21:31 EDT (History)
9 users (show)

See Also:
Fixed In Version: 3.6.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-04-19 21:31:54 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Virt
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 22663 None None None Never

  None (edit)
Description Jiri Belka 2013-05-31 08:42:52 EDT
Description of problem:
BZ907997 introduced Run Once event messages but there's little chaos if it is combined with Paused state.

a/ normally run once - stateless (FYI I opened BZ969440 so 2nd msg is in simple past)

1. Starting VM YYYYYY was initiated by admin@internal.                 (code=USER_INITIATED_RUN_VM)
2. VM YYYYYY was restarted on Host XXXX.redhat.com                     (code=VDS_INITIATED_RUN_VM)

b/ run once - stateless + paused

1. Starting VM YYYYYY was initiated by admin@internal.                 (code=USER_INITIATED_RUN_VM)
2. VM YYYYYY was resumed by admin@internal (Host: xxxxx).
3. VM YYYYYY was resumed by admin@internal (Host: xxxxx).

See '2.' is (probably) about starting the VM from paused mode.
Shouldn't then '3.' have '(was) restarted' message to tell an user that the VM is finally up?

'/b' applies to Run Once - paused (stateful) as well.

Wouldn't be nice to have it like this?

* was started/was initiated
* was paused (if applicable)
* was resumed (if applicable)
* started/restarted

Anyway, I still don't understand why you didn't make it obvious in the first message like 'was initiated in paused mode' and you have implemented these events in even more cryptic way :-)

Version-Release number of selected component (if applicable):
sf17.1

How reproducible:
100%

Steps to Reproduce:
1. run once - paused (stateful) -> see events
2. run once - paused + stateless -> see events
3. compare with same actions but not in 'paused' mode

Actual results:
run once - paused mode event messages look odd

Expected results:
(as whole events are cryptic anyway) still make them more clean to users

Additional info:
Comment 1 Itamar Heim 2013-12-01 14:43:14 EST
what's the actual change needed to fix this?
Comment 2 Michal Skrivanek 2013-12-02 10:16:37 EST
a different messages at different point, not particularly difficult. Just need to try all cases and verify it fires the right events
Comment 4 Michal Skrivanek 2014-08-22 09:01:32 EDT
this bug won't fit into 3.5 release and is being deferred to a later release. If you deeply care about this bug and deserves to be re-evaluated please let me know
Comment 5 Omer Frenkel 2015-08-26 07:59:52 EDT
fixed long ago, on 3.6 i get (order is from new to old, as shown in the ui):

 VM lightVm started on Host dubi as stateless
 VM lightVm was resumed by admin@internal (Host: dubi).
 VM lightVm has been paused.
 Starting VM lightVm was initiated by admin@internal.

please verify
Comment 6 sefi litmanovich 2015-11-19 07:52:46 EST
Verified with rhevm-3.6.0.3-0.1.el6.noarch.

1. runOnce Vm as stateless + pause mode:

"Starting VM YYYYY was initiated by admin@internal."
"VM YYYYY has been paused."
after resuming VM:
"VM YYYYY was resumed by admin@internal (Host: host_mixed_3)."
"VM YYYYY started on Host host_mixed_3 as stateless"

2.runOnce Vm as statefull + pause mode:

"Starting in paused mode VM YYYYY was initiated by admin@internal."
"VM YYYYY has been paused."
after resuming VM:
"VM YYYYY was resumed by admin@internal (Host: host_mixed_3)."
"VM YYYYY started on Host host_mixed_3"

3.runOnce Vm as stateless normally (not paused):
"Starting VM YYYYY was initiated by admin@internal."
"VM YYYYY was restarted on Host host_mixed_3 as stateless

This is almost perfect and much better than results in the bug description, with the small exception that I would expect that in case (1) the initial message would be: 
"Starting in paused mode VM YYYYY was initiated by admin@internal." similar to case (2).

The behaviour is valid and good and so I am verifying and adding needinfo to raise the question whether we want to make this last adjustment I mentioned or not.
Comment 7 Arik 2015-11-19 11:03:42 EST
I agree and the fix is trivial (https://gerrit.ovirt.org/#/c/48840/1).
If you think it should be backported to 3.6 then reopen the bug.
I think that since it is not part of this bug and the severity is low, we can push it to 4.0. in that case, worth opening a bug for 4.0 so it will be verified then.

Note You need to log in before you can comment on or make changes to this bug.