Bug 969509 - modinfo seqmentation fault
modinfo seqmentation fault
Status: CLOSED DUPLICATE of bug 972588
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: module-init-tools (Show other bugs)
6.4
x86_64 Linux
unspecified Severity low
: rc
: ---
Assigned To: David Shea
qe-baseos-daemons
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-31 11:39 EDT by Tommi Tervo
Modified: 2013-06-13 14:26 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-13 14:26:35 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
valgrind log (8.48 KB, text/plain)
2013-05-31 11:39 EDT, Tommi Tervo
no flags Details

  None (edit)
Description Tommi Tervo 2013-05-31 11:39:05 EDT
Created attachment 755313 [details]
valgrind log

Description of problem:
modinfo commands segfaults. I cleaned up some old kernel packages, so weak-updates may have broken symlinks to non-existing modules but I think modinfo should not crash.

 

filename:       /lib/modules/2.6.32-358.6.1.el6.x86_64/kernel/net/ipv6/netfilter/ip6_tables.ko
description:    IPv6 packet filter
author:         Netfilter Core Team <coreteam@netfilter.org>
license:        GPL
srcversion:     3887490E0C6B9656701FB18
depends:        
vermagic:       2.6.32-358.6.1.el6.x86_64 SMP mod_unload modversions 
Segmentation fault (core dumped)


Version-Release number of selected component (if applicable):

module-init-tools-3.9-21.el6.x86_64
How reproducible:
always

Steps to Reproduce:
1. modinfo bridge ipt_MASQUERADE ipt_REDIRECT ip_vs_rr iptable_nat nf_nat ip_vs autofs4 lmv mgc lustre lov osc lquota mdc fid fld ko2iblnd ptlrpc obdclass lnet lvfs libcfs sunrpc ipmi_devintf cpufreq_ondemand freq_table pcc_cpufreq bonding 8021q garp stp llc ipt_REJECT nf_conntrack_ipv4 nf_defrag_ipv4 iptable_filter ip_tables ip6t_LOG ip6t_REJECT nf_conntrack_ipv6 nf_defrag_ipv6 xt_state nf_conntrack xt_hashlimit ip6table_filter ip6_tables rdma_ucm ib_ucm rdma_cm iw_cm ib_addr ib_ipoib ib_cm ib_sa ipv6 ib_uverbs ib_umad iw_nes libcrc32c ib_qib mlx4_ib ib_mthca ib_mad ib_core power_meter hpilo hpwdt qlcnic mlx4_en mlx4_core tg3 microcode serio_raw sg iTCO_wdt iTCO_vendor_support ioatdma dca shpchp ext4 mbcache jbd2 sd_mod crc_t10dif sr_mod cdrom hpsa pata_acpi ata_generic ata_piix dm_mirror dm_region_hash dm_log dm_mod
2.
3.

Actual results:
segfault

Expected results:
!segfault

Additional info:

Core was generated by `/sbin/modinfo bridge ipt_MASQUERADE ipt_REDIRECT ip_vs_rr iptable_nat nf_nat ip'.                                                                                             
Program terminated with signal 11, Segmentation fault.                                                                                                                                               
#0  0x00000035090480ac in _IO_vfprintf_internal (s=<value optimized out>, format=<value optimized out>, ap=<value optimized out>) at vfprintf.c:1641                                                 
1641              process_string_arg (((struct printf_spec *) NULL));                                                                                                                                
(gdb) bt                                                                                                                                                                                             
#0  0x00000035090480ac in _IO_vfprintf_internal (s=<value optimized out>, format=<value optimized out>, ap=<value optimized out>) at vfprintf.c:1641                                                 
#1  0x0000003509101e6c in __vasprintf_chk (result_ptr=0x7fff99cc6498, flags=1, format=0x40e3d0 "modinfo: could not open %s: %s\n", args=0x7fff99cc64c0) at vasprintf_chk.c:68                        
#2  0x000000000040c05e in vasprintf (prefix=0x414306 "ERROR: ", fmt=<value optimized out>, arglist=<value optimized out>) at /usr/include/bits/stdio2.h:199                                          
#3  message (prefix=0x414306 "ERROR: ", fmt=<value optimized out>, arglist=<value optimized out>) at ../logging.c:24                                                                                 
#4  0x000000000040c243 in error (fmt=<value optimized out>) at ../logging.c:56                                                                                                                       
#5  0x0000000000401805 in grab_module (name=<value optimized out>, kernel=<value optimized out>, basedir=<value optimized out>) at ../modinfo.c:244                                                  
#6  0x0000000000401d92 in main (argc=96, argv=<value optimized out>) at ../modinfo.c:305
Comment 1 David Shea 2013-06-13 14:26:35 EDT

*** This bug has been marked as a duplicate of bug 972588 ***

Note You need to log in before you can comment on or make changes to this bug.