Bug 969632 - [abrt] radiotray-0.7.1-3.fc18: _dbus_watch_invalidate: Process /usr/bin/python2.7 was killed by signal 11 (SIGSEGV)
[abrt] radiotray-0.7.1-3.fc18: _dbus_watch_invalidate: Process /usr/bin/pytho...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: radiotray (Show other bugs)
18
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jean-Francois Saucier
Fedora Extras Quality Assurance
abrt_hash:487bc613aa587702c55af50bf8c...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-01 02:44 EDT by david sutherland
Modified: 2013-08-07 10:34 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-07 10:34:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (51.21 KB, text/plain)
2013-06-01 02:45 EDT, david sutherland
no flags Details
File: cgroup (128 bytes, text/plain)
2013-06-01 02:45 EDT, david sutherland
no flags Details
File: core_backtrace (4.27 KB, text/plain)
2013-06-01 02:45 EDT, david sutherland
no flags Details
File: dso_list (15.83 KB, text/plain)
2013-06-01 02:45 EDT, david sutherland
no flags Details
File: environ (1.31 KB, text/plain)
2013-06-01 02:45 EDT, david sutherland
no flags Details
File: limits (1.29 KB, text/plain)
2013-06-01 02:45 EDT, david sutherland
no flags Details
File: maps (73.12 KB, text/plain)
2013-06-01 02:45 EDT, david sutherland
no flags Details
File: open_fds (723 bytes, text/plain)
2013-06-01 02:45 EDT, david sutherland
no flags Details
File: proc_pid_status (938 bytes, text/plain)
2013-06-01 02:45 EDT, david sutherland
no flags Details
File: var_log_messages (652 bytes, text/plain)
2013-06-01 02:45 EDT, david sutherland
no flags Details

  None (edit)
Description david sutherland 2013-06-01 02:44:57 EDT
Description of problem:
The problem is when I click on radio tray.  Nothing happens.  It just reports a bug.  Can be reproduced by clicking on radio tray again.  It also shows that radio tray is on, but it is not.

Version-Release number of selected component:
radiotray-0.7.1-3.fc18

Additional info:
reporter:       libreport-2.1.4
backtrace_rating: 4
cmdline:        /usr/bin/python /usr/bin/radiotray
crash_function: _dbus_watch_invalidate
executable:     /usr/bin/python2.7
kernel:         3.9.4-200.fc18.x86_64
runlevel:       N 5
uid:            1000
xsession_errors: 

Truncated backtrace:
Thread no. 1 (10 frames)
 #0 _dbus_watch_invalidate at dbus-watch.c:171
 #1 free_watches at dbus-transport-socket.c:83
 #2 socket_disconnect at dbus-transport-socket.c:987
 #3 _dbus_transport_disconnect at dbus-transport.c:509
 #5 _dbus_transport_queue_messages at dbus-transport.c:1165
 #6 do_reading at dbus-transport-socket.c:851
 #8 socket_do_iteration at dbus-transport-socket.c:1162
 #9 _dbus_transport_do_iteration at dbus-transport.c:976
 #10 _dbus_connection_do_iteration_unlocked at dbus-connection.c:1234
 #11 _dbus_connection_block_pending_call at dbus-connection.c:2415

Potential duplicate: bug 810654
Comment 1 david sutherland 2013-06-01 02:45:02 EDT
Created attachment 755463 [details]
File: backtrace
Comment 2 david sutherland 2013-06-01 02:45:05 EDT
Created attachment 755464 [details]
File: cgroup
Comment 3 david sutherland 2013-06-01 02:45:08 EDT
Created attachment 755465 [details]
File: core_backtrace
Comment 4 david sutherland 2013-06-01 02:45:11 EDT
Created attachment 755466 [details]
File: dso_list
Comment 5 david sutherland 2013-06-01 02:45:13 EDT
Created attachment 755467 [details]
File: environ
Comment 6 david sutherland 2013-06-01 02:45:15 EDT
Created attachment 755468 [details]
File: limits
Comment 7 david sutherland 2013-06-01 02:45:21 EDT
Created attachment 755469 [details]
File: maps
Comment 8 david sutherland 2013-06-01 02:45:23 EDT
Created attachment 755470 [details]
File: open_fds
Comment 9 david sutherland 2013-06-01 02:45:26 EDT
Created attachment 755471 [details]
File: proc_pid_status
Comment 10 david sutherland 2013-06-01 02:45:28 EDT
Created attachment 755472 [details]
File: var_log_messages
Comment 11 Jean-Francois Saucier 2013-08-07 10:34:21 EDT
Thank you for reporting this bug. I just submitted a new update of Radiotray
(0.7.3) to Fedora and you should see it in your list of updates soon.

Please report back here if your problem is still present in this new version.

Please fell free to reopen it or report a new one if you have any problem with
Radiotray.

Note You need to log in before you can comment on or make changes to this bug.