Bug 969655 - DeviceTreeError: duplicate uuids in device tree
DeviceTreeError: duplicate uuids in device tree
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
19
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
abrt_hash:78a91a917a833940b1c02c44259...
:
: 967094 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-01 10:32 EDT by Flóki Pálsson
Modified: 2014-12-08 17:21 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-03-07 08:07:20 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: anaconda-tb (977.21 KB, text/plain)
2013-06-01 10:33 EDT, Flóki Pálsson
no flags Details
File: anaconda.log (12.67 KB, text/plain)
2013-06-01 10:33 EDT, Flóki Pálsson
no flags Details
File: backtrace (494 bytes, text/plain)
2013-06-01 10:33 EDT, Flóki Pálsson
no flags Details
File: environ (769 bytes, text/plain)
2013-06-01 10:33 EDT, Flóki Pálsson
no flags Details
File: ifcfg.log (490 bytes, text/plain)
2013-06-01 10:33 EDT, Flóki Pálsson
no flags Details
File: lsblk_output (5.66 KB, text/plain)
2013-06-01 10:33 EDT, Flóki Pálsson
no flags Details
File: messages (294.15 KB, text/plain)
2013-06-01 10:33 EDT, Flóki Pálsson
no flags Details
File: nmcli_dev_list (3.27 KB, text/plain)
2013-06-01 10:33 EDT, Flóki Pálsson
no flags Details
File: program.log (121.15 KB, text/plain)
2013-06-01 10:33 EDT, Flóki Pálsson
no flags Details
File: storage.log (530.69 KB, text/plain)
2013-06-01 10:33 EDT, Flóki Pálsson
no flags Details

  None (edit)
Description Flóki Pálsson 2013-06-01 10:32:56 EDT
Description of problem:
recheck disk selection
The following was filed automatically by anaconda:
anaconda 19.30-1 exception report
Traceback (most recent call first):
  File "/usr/lib/python2.7/site-packages/blivet/devicetree.py", line 2083, in devices
    raise DeviceTreeError("duplicate uuids in device tree")
  File "/usr/lib/python2.7/site-packages/blivet/__init__.py", line 454, in devices
    devices = self.devicetree.devices
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/storage.py", line 768, in on_back_clicked
    disk in self.storage.devices:
DeviceTreeError: duplicate uuids in device tree

Version-Release number of selected component:
anaconda-19.30-1.fc19.x86_64

Additional info:
reporter:       libreport-2.1.4
cmdline:        /usr/bin/python  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-osimg-min --lang en_US.UTF-8
cmdline_file:   initrd=initrd0.img root=live:CDLABEL=Fedora-Live-Desktop-x86_64-19-Be rootfstype=auto ro rd.live.image quiet  rhgb rd.luks=0 rd.md=0 rd.dm=0  BOOT_IMAGE=vmlinuz0 
core_backtrace: 
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         3.9.2-301.fc19.x86_64
other involved packages: python-blivet-0.14-1.fc19.noarch
packaging.log:  
product:        Fedora
release:        Fedora release 19 (Schrödinger’s Cat)
type:           anaconda
version:        19

Truncated backtrace:
Traceback (most recent call last):
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/storage.py", line 768, in on_back_clicked
    disk in self.storage.devices:
  File "/usr/lib/python2.7/site-packages/blivet/__init__.py", line 454, in devices
    devices = self.devicetree.devices
  File "/usr/lib/python2.7/site-packages/blivet/devicetree.py", line 2083, in devices
    raise DeviceTreeError("duplicate uuids in device tree")
DeviceTreeError: duplicate uuids in device tree
Comment 1 Flóki Pálsson 2013-06-01 10:33:05 EDT
Created attachment 755538 [details]
File: anaconda-tb
Comment 2 Flóki Pálsson 2013-06-01 10:33:10 EDT
Created attachment 755539 [details]
File: anaconda.log
Comment 3 Flóki Pálsson 2013-06-01 10:33:14 EDT
Created attachment 755540 [details]
File: backtrace
Comment 4 Flóki Pálsson 2013-06-01 10:33:17 EDT
Created attachment 755541 [details]
File: environ
Comment 5 Flóki Pálsson 2013-06-01 10:33:22 EDT
Created attachment 755542 [details]
File: ifcfg.log
Comment 6 Flóki Pálsson 2013-06-01 10:33:26 EDT
Created attachment 755543 [details]
File: lsblk_output
Comment 7 Flóki Pálsson 2013-06-01 10:33:31 EDT
Created attachment 755544 [details]
File: messages
Comment 8 Flóki Pálsson 2013-06-01 10:33:35 EDT
Created attachment 755545 [details]
File: nmcli_dev_list
Comment 9 Flóki Pálsson 2013-06-01 10:33:39 EDT
Created attachment 755546 [details]
File: program.log
Comment 10 Flóki Pálsson 2013-06-01 10:33:45 EDT
Created attachment 755547 [details]
File: storage.log
Comment 11 David Shea 2014-03-04 16:37:11 EST
Can you provide steps to reproduce this error? Does it still occur in F20 or rawhide?
Comment 12 Flóki Pálsson 2014-03-06 18:05:14 EST
(In reply to David Shea from comment #11)
> Can you provide steps to reproduce this error? Does it still occur in F20 or
> rawhide?

No.
Comment 13 David Shea 2014-12-08 17:21:03 EST
*** Bug 967094 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.