Bug 969691 - Can't SSH connect to application or restart it using CLI tools
Can't SSH connect to application or restart it using CLI tools
Status: CLOSED NOTABUG
Product: OpenShift Online
Classification: Red Hat
Component: Pod (Show other bugs)
2.x
Unspecified Unspecified
unspecified Severity low
: ---
: ---
Assigned To: Abhishek Gupta
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-01 17:10 EDT by Dmitry Gusev
Modified: 2015-05-14 20:17 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-03 12:15:18 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dmitry Gusev 2013-06-01 17:10:52 EDT
Description of problem:

I can't connect by SSH, git also doesn't work.

I can't restart app using client tools:

$ rhc app restart -a satago -d
DEBUG: Connecting to https://openshift.redhat.com/broker/rest/api
DEBUG: Getting all domains
DEBUG: Request GET https://openshift.redhat.com/broker/rest/api
DEBUG:    code 200 1008 ms
Password: *************
DEBUG: Request GET https://openshift.redhat.com/broker/rest/domains

DEBUG:    code 200 11008 ms
DEBUG: Getting all domains
DEBUG: Request GET https://openshift.redhat.com/broker/rest/domains/anjlab/applications/satago
DEBUG:    code 200  890 ms
DEBUG: Restarting application satago
DEBUG: Request POST https://openshift.redhat.com/broker/rest/domains/anjlab/applications/satago/events
DEBUG:    code 500 121369 ms
Unable to complete the requested operation due to: Node execution failure (invalid exit code from node).  If the problem persists please contact Red Hat support..
Reference ID: e7528f5fc27f3609da72decaccf723bc


and can't force-stop it:

$ rhc app force-stop satago -d
DEBUG: Connecting to https://openshift.redhat.com/broker/rest/api
DEBUG: Getting all domains
DEBUG: Request GET https://openshift.redhat.com/broker/rest/api
DEBUG:    code 200  945 ms
Password: *************
DEBUG: Request GET https://openshift.redhat.com/broker/rest/domains
DEBUG:    code 200  600 ms
DEBUG: Getting all domains
DEBUG: Request GET https://openshift.redhat.com/broker/rest/domains/anjlab/applications/satago
DEBUG:    code 200  954 ms
DEBUG: Stopping application satago force-true
DEBUG: Request POST https://openshift.redhat.com/broker/rest/domains/anjlab/applications/satago/events
DEBUG:    code 500 240972 ms
Node execution failure (error getting result from node).  If the problem persists please contact Red Hat support.


This happened first time May 31 after I tried to git push and the problem still persists...
Comment 1 Dmitry Gusev 2013-06-02 07:49:25 EDT
I was able to connect just now, not sure whats happened.
Comment 2 Xiaoli Tian 2013-06-03 00:01:50 EDT
Set it to low severity according to comment 1 since it works now.
Comment 3 Xiaoli Tian 2013-06-03 00:01:51 EDT
Set it to low severity according to comment 1 since it works now.
Comment 4 Nam Duong 2013-06-03 12:15:18 EDT
This issue was being tracked over the weekend though ended up being a load issue on the node/host.  The node/host was rebooted, freeing up the gear to be restarted at will by the user.

Note You need to log in before you can comment on or make changes to this bug.