Bug 969717 - SELinux is preventing /usr/bin/rm from 'unlink' accesses on the lnk_file vboxguest-4.2.51.
SELinux is preventing /usr/bin/rm from 'unlink' accesses on the lnk_file vbox...
Status: CLOSED DUPLICATE of bug 969711
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
19
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:d27630c9f2c9d8e9f3fb51546d4...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-01 21:36 EDT by Moez Roy
Modified: 2013-06-03 01:58 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-03 01:58:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Moez Roy 2013-06-01 21:36:02 EDT
Description of problem:
SELinux is preventing /usr/bin/rm from 'unlink' accesses on the lnk_file vboxguest-4.2.51.

*****  Plugin catchall_labels (83.8 confidence) suggests  ********************

If you want to allow rm to have unlink access on the vboxguest-4.2.51 lnk_file
Then you need to change the label on vboxguest-4.2.51
Do
# semanage fcontext -a -t FILE_TYPE 'vboxguest-4.2.51'
where FILE_TYPE is one of the following: NetworkManager_tmp_t, NetworkManager_unit_file_t, abrt_tmp_t, abrt_unit_file_t, abrt_var_cache_t, accountsd_unit_file_t, admin_crontab_tmp_t, alsa_tmp_t, alsa_unit_file_t, amanda_tmp_t, antivirus_tmp_t, antivirus_unit_file_t, apcupsd_lock_t, apcupsd_tmp_t, apcupsd_unit_file_t, apmd_lock_t, apmd_tmp_t, apmd_unit_file_t, arpwatch_tmp_t, arpwatch_unit_file_t, asterisk_tmp_t, auditadm_sudo_tmp_t, auditd_unit_file_t, automount_lock_t, automount_tmp_t, automount_unit_file_t, avahi_unit_file_t, awstats_tmp_t, bcfg2_unit_file_t, bitlbee_tmp_t, bluetooth_helper_tmp_t, bluetooth_lock_t, bluetooth_tmp_t, bluetooth_unit_file_t, boinc_project_tmp_t, boinc_tmp_t, boinc_unit_file_t, bootloader_tmp_t, cardmgr_dev_t, ccs_tmp_t, cdcc_tmp_t, chrome_sandbox_tmp_t, chronyd_unit_file_t, cluster_tmp_t, cluster_unit_file_t, cobbler_tmp_t, collectd_unit_file_t, colord_tmp_t, colord_unit_file_t, comsat_tmp_t, condor_master_tmp_t, condor_schedd_tmp_t, condor_startd_tmp_t, condor_unit_file_t, condor_var_lock_t, consolekit_unit_file_t, couchdb_tmp_t, couchdb_unit_file_t, crack_tmp_t, crond_tmp_t, crond_unit_file_t, crontab_tmp_t, ctdbd_tmp_t, cups_pdf_tmp_t, cupsd_lock_t, cupsd_lpd_tmp_t, cupsd_tmp_t, cupsd_unit_file_t, cvs_tmp_t, cyphesis_tmp_t, cyrus_tmp_t, dbadm_sudo_tmp_t, dbskkd_tmp_t, dcc_client_tmp_t, dcc_dbclean_tmp_t, dccd_tmp_t, dccifd_tmp_t, dccm_tmp_t, ddclient_tmp_t, deltacloudd_tmp_t, denyhosts_var_lock_t, device_t, devicekit_tmp_t, dhcpc_tmp_t, dhcpd_tmp_t, dhcpd_unit_file_t, dirsrv_tmp_t, dirsrv_var_lock_t, dirsrvadmin_lock_t, dirsrvadmin_tmp_t, disk_munin_plugin_tmp_t, dnsmasq_unit_file_t, dovecot_auth_tmp_t, dovecot_deliver_tmp_t, dovecot_tmp_t, drbd_lock_t, etc_aliases_t, etc_t, exim_tmp_t, fail2ban_tmp_t, fenced_lock_t, fenced_tmp_t, file_t, firewalld_tmp_t, firewalld_unit_file_t, firewallgui_tmp_t, fonts_t, fsadm_tmp_t, fsdaemon_tmp_t, ftpd_lock_t, ftpd_tmp_t, ftpd_unit_file_t, ftpdctl_tmp_t, games_tmp_t, gconf_tmp_t, getty_lock_t, getty_tmp_t, getty_unit_file_t, gkeyringd_tmp_t, glance_registry_tmp_t, glance_tmp_t, glusterd_tmp_t, gpg_agent_tmp_t, gpg_pinentry_tmp_t, gpm_tmp_t, gssd_tmp_t, httpd_bugzilla_tmp_t, httpd_collectd_script_tmp_t, httpd_lock_t, httpd_mojomojo_tmp_t, httpd_munin_script_tmp_t, httpd_php_tmp_t, httpd_suexec_tmp_t, httpd_tmp_t, httpd_unit_file_t, inetd_child_tmp_t, inetd_tmp_t, initrc_state_t, initrc_tmp_t, ipsec_mgmt_lock_t, ipsec_mgmt_unit_file_t, ipsec_tmp_t, iptables_tmp_t, iptables_unit_file_t, iscsi_lock_t, iscsi_tmp_t, iscsi_unit_file_t, kadmind_tmp_t, kdump_unit_file_t, kdumpctl_tmp_t, kdumpgui_tmp_t, keystone_tmp_t, keystone_unit_file_t, kismet_tmp_t, kismet_tmpfs_t, klogd_tmp_t, krb5_host_rcache_t, krb5kdc_lock_t, krb5kdc_tmp_t, ksmtuned_unit_file_t, ktalkd_tmp_t, l2tpd_tmp_t, ldconfig_tmp_t, likewise_pstore_lock_t, livecd_tmp_t, local_login_lock_t, locale_t, lockdev_lock_t, logrotate_lock_t, logrotate_mail_tmp_t, logrotate_tmp_t, logwatch_lock_t, logwatch_mail_tmp_t, logwatch_tmp_t, lpd_tmp_t, lpr_tmp_t, lsassd_tmp_t, lvm_lock_t, lvm_tmp_t, lvm_unit_file_t, mail_munin_plugin_tmp_t, mailman_cgi_tmp_t, mailman_lock_t, mailman_mail_tmp_t, mailman_queue_tmp_t, mandb_lock_t, mock_tmp_t, mongod_tmp_t, mount_tmp_t, mozilla_plugin_tmp_t, mozilla_tmp_t, mpd_tmp_t, mrtg_lock_t, mscan_tmp_t, munin_tmp_t, mysqld_tmp_t, mysqld_unit_file_t, nagios_eventhandler_plugin_tmp_t, nagios_system_plugin_tmp_t, nagios_tmp_t, named_tmp_t, named_unit_file_t, netutils_tmp_t, nfsd_unit_file_t, nis_unit_file_t, nova_ajax_tmp_t, nova_ajax_unit_file_t, nova_api_tmp_t, nova_api_unit_file_t, nova_cert_tmp_t, nova_cert_unit_file_t, nova_compute_tmp_t, nova_compute_unit_file_t, nova_console_tmp_t, nova_console_unit_file_t, nova_direct_tmp_t, nova_direct_unit_file_t, nova_network_tmp_t, nova_network_unit_file_t, nova_objectstore_tmp_t, nova_objectstore_unit_file_t, nova_scheduler_tmp_t, nova_scheduler_unit_file_t, nova_vncproxy_tmp_t, nova_vncproxy_unit_file_t, nova_volume_tmp_t, nova_volume_unit_file_t, nscd_unit_file_t, ntop_tmp_t, ntpd_tmp_t, ntpd_unit_file_t, numad_unit_file_t, nut_unit_file_t, nx_server_tmp_t, oddjob_unit_file_t, openshift_cgroup_read_tmp_t, openshift_cron_tmp_t, openshift_initrc_tmp_t, openshift_tmp_t, openvpn_tmp_t, openvswitch_unit_file_t, pam_timestamp_tmp_t, passenger_tmp_t, pegasus_tmp_t, piranha_web_tmp_t, pkcsslotd_lock_t, pkcsslotd_tmp_t, pkcsslotd_unit_file_t, pki_ra_lock_t, pki_tomcat_lock_t, pki_tomcat_tmp_t, pki_tomcat_unit_file_t, pki_tps_lock_t, podsleuth_tmp_t, policykit_tmp_t, polipo_unit_file_t, portmap_tmp_t, postfix_bounce_tmp_t, postfix_cleanup_tmp_t, postfix_local_tmp_t, postfix_map_tmp_t, postfix_pickup_tmp_t, postfix_pipe_tmp_t, postfix_qmgr_tmp_t, postfix_smtp_tmp_t, postfix_smtpd_tmp_t, postfix_virtual_tmp_t, postgresql_db_t, postgresql_lock_t, postgresql_tmp_t, power_unit_file_t, pppd_lock_t, pppd_tmp_t, pppd_unit_file_t, prelink_tmp_t, prelude_lml_tmp_t, procmail_tmp_t, psad_tmp_t, puppet_tmp_t, puppetmaster_tmp_t, qpidd_tmp_t, qpidd_var_run_t, quantum_tmp_t, quantum_unit_file_t, racoon_tmp_t, radiusd_unit_file_t, realmd_tmp_t, rhev_agentd_tmp_t, rhev_agentd_unit_file_t, rhsmcertd_lock_t, ricci_modstorage_lock_t, ricci_tmp_t, rlogind_tmp_t, rngd_unit_file_t, rpcd_unit_file_t, rpm_script_tmp_t, rpm_tmp_t, rsync_tmp_t, samba_net_tmp_t, samba_unit_file_t, sanlock_unit_file_t, secadm_sudo_tmp_t, sectool_tmp_t, selinux_munin_plugin_tmp_t, semanage_read_lock_t, semanage_tmp_t, semanage_trans_lock_t, sendmail_tmp_t, sensord_unit_file_t, services_munin_plugin_tmp_t, session_dbusd_tmp_t, sge_tmp_t, shorewall_lock_t, shorewall_tmp_t, slapd_lock_t, slapd_tmp_t, slapd_unit_file_t, smbd_tmp_t, smoltclient_tmp_t, smsd_tmp_t, snort_tmp_t, sosreport_tmp_t, soundd_tmp_t, spamc_tmp_t, spamd_tmp_t, squid_tmp_t, squirrelmail_spool_t, ssh_agent_tmp_t, sshd_unit_file_t, sssd_unit_file_t, staff_sudo_tmp_t, stapserver_tmp_t, stunnel_tmp_t, svc_svc_t, svirt_tmp_t, svnserve_tmp_t, svnserve_unit_file_t, swat_tmp_t, swift_unit_file_t, sysadm_passwd_tmp_t, sysadm_sudo_tmp_t, syslogd_tmp_t, system_cronjob_lock_t, system_cronjob_tmp_t, system_dbusd_tmp_t, system_mail_tmp_t, system_munin_plugin_tmp_t, systemd_unit_file_t, tcpd_tmp_t, telepathy_gabble_tmp_t, telepathy_idle_tmp_t, telepathy_logger_tmp_t, telepathy_mission_control_tmp_t, telepathy_msn_tmp_t, telepathy_salut_tmp_t, telepathy_sofiasip_tmp_t, telepathy_stream_engine_tmp_t, telepathy_sunshine_tmp_t, telnetd_tmp_t, tetex_data_t, tgtd_tmp_t, thumb_tmp_t, tmp_t, tmpfs_t, tomcat_tmp_t, tomcat_unit_file_t, tor_unit_file_t, tuned_tmp_t, tvtime_tmp_t, uml_tmp_t, unconfined_munin_plugin_tmp_t, update_modules_tmp_t, usbmuxd_unit_file_t, user_fonts_t, user_mail_tmp_t, user_tmp_t, uucpd_lock_t, uucpd_tmp_t, var_lock_t, var_run_t, var_spool_t, varnishd_tmp_t, virt_cache_t, virt_lock_t, virt_qemu_ga_tmp_t, virt_tmp_t, virtd_unit_file_t, vmware_host_tmp_t, vmware_tmp_t, vpnc_tmp_t, webadm_tmp_t, webalizer_tmp_t, wine_tmp_t, wireshark_tmp_t, xauth_tmp_t, xdm_lock_t, xdm_tmp_t, xend_tmp_t, xenstored_tmp_t, ypbind_tmp_t, ypbind_unit_file_t, ypserv_tmp_t, zabbix_tmp_t, zarafa_deliver_tmp_t, zarafa_indexer_tmp_t, zarafa_server_tmp_t, zarafa_var_lib_t, zebra_tmp_t. 
Then execute: 
restorecon -v 'vboxguest-4.2.51'


*****  Plugin catchall (17.1 confidence) suggests  ***************************

If you believe that rm should be allowed unlink access on the vboxguest-4.2.51 lnk_file by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# grep rm /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                unconfined_u:system_r:initrc_t:s0
Target Context                unconfined_u:object_r:usr_t:s0
Target Objects                vboxguest-4.2.51 [ lnk_file ]
Source                        rm
Source Path                   /usr/bin/rm
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           coreutils-8.21-11.fc19.x86_64
Target RPM Packages           
Policy RPM                    selinux-policy-3.12.1-47.fc19.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Host Name                     (removed)
Platform                      Linux (removed) 3.9.4-300.fc19.x86_64 #1 SMP Fri
                              May 24 22:17:06 UTC 2013 x86_64 x86_64
Alert Count                   1
First Seen                    2013-06-01 21:21:49 EDT
Last Seen                     2013-06-01 21:21:49 EDT
Local ID                      8b94f86d-bf14-4244-bf7a-01069395acef

Raw Audit Messages
type=AVC msg=audit(1370136109.706:517): avc:  denied  { unlink } for  pid=3846 comm="rm" name="vboxguest-4.2.51" dev="sda2" ino=533767 scontext=unconfined_u:system_r:initrc_t:s0 tcontext=unconfined_u:object_r:usr_t:s0 tclass=lnk_file


type=SYSCALL msg=audit(1370136109.706:517): arch=x86_64 syscall=unlinkat success=no exit=EACCES a0=ffffffffffffff9c a1=239f0c0 a2=0 a3=7fff829d3c50 items=0 ppid=3074 pid=3846 auid=1000 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 ses=1 tty=pts0 comm=rm exe=/usr/bin/rm subj=unconfined_u:system_r:initrc_t:s0 key=(null)

Hash: rm,initrc_t,usr_t,lnk_file,unlink

Additional info:
reporter:       libreport-2.1.4
hashmarkername: setroubleshoot
kernel:         3.9.4-300.fc19.x86_64
type:           libreport
Comment 1 Miroslav Grepl 2013-06-03 01:58:23 EDT

*** This bug has been marked as a duplicate of bug 969711 ***

Note You need to log in before you can comment on or make changes to this bug.