Bug 969719 - setup_rewritten in managed_files.yml doesn't do anything
setup_rewritten in managed_files.yml doesn't do anything
Status: CLOSED NOTABUG
Product: OpenShift Online
Classification: Red Hat
Component: Containers (Show other bugs)
2.x
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Jhon Honce
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-01 21:47 EDT by Dan McPherson
Modified: 2015-05-14 19:20 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-04 19:29:23 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dan McPherson 2013-06-01 21:47:52 EDT
Description of problem:

According to:

https://github.com/openshift/origin-server/blob/master/node/README.writing_cartridges.md

It's supposed to delete those listings before rerunning setup.  It seems to do nothing.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Add blah to setup_rewritten in managed_files.yml of a cart
2. touch blah
3. Rerun a setup file that fails if blah exists and then writes blah

Actual results:
It fails

Expected results:
Should succeed because setup_rewritten specified blah

Additional info:
Comment 1 Jhon Honce 2013-06-04 19:29:23 EDT
The setup script is currently run in two scenarios:

1) on cartridge create: No files exist so there are no files to delete
2) on cartridge migration: setup_rewritten files are removed in this case

Please reopen bug if there is a scenario that has been missed.
Comment 2 Dan McPherson 2013-06-04 20:14:44 EDT
Sorry I searched for the code before and missed the code in migrate.rb (and my scenario I listed wasn't really correct.  Should have referenced the migration.).  There is one scenario missed but hasn't been implemented yet to handle upgrading downloadable carts.

Note You need to log in before you can comment on or make changes to this bug.