Bug 96973 - kernel will not work with over 896MB memory
kernel will not work with over 896MB memory
Status: CLOSED DUPLICATE of bug 96974
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
9
athlon Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-06-07 09:14 EDT by zic
Modified: 2007-04-18 12:54 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:56:37 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description zic 2003-06-07 09:14:19 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4b) Gecko/20030507

Description of problem:
HIGHMEM with real page (i.e. having memory over 896MB)
    cause several problems
    such as boot crash, vmalloc32 failure, etc.
No error when limit memory with boot command line option MEM=896M.


Version-Release number of selected component (if applicable):
kenel 2.4.20-13.9

How reproducible:
Always

Steps to Reproduce:
1. install kernel(kernel-2.4.20-13.9.athlon.rpm or
kernel-smp-2.4.20-13.9.athlon.rpm) on a machine with over 896MB memory.
2. boot
3. kernel panic

Note. sometimes, on some condition, boot will work.
    but when you continue to work on that machine, something funny with memory
allocation(such as vmalloc32) would occur.


Actual Results:  (1) kernel panic
    see screen shot attached


(2) vmalloc32 fail if luckily success to boot.


Expected Results:  Boot fine, work fine.

Additional info:

"Actual Results (2)"


May 15 21:18:17 Linux kernel: get_cnode failed!
May 15 21:18:17 Linux kernel: ------------[ cut here ]------------
May 15 21:18:17 Linux kernel: kernel BUG at prints.c:334!
May 15 21:18:17 Linux kernel: invalid operand: 0000
May 15 21:18:17 Linux kernel: nls_euc-jp nls_cp932 vfat fat emu10k1 sound
ac97_codec nfs bttv videodev i2c-algo-bit i2c-core soundcore radeon agpgart
scsi_debug binfmt_misc appletalk nfsd 
May 15 21:18:17 Linux kernel: CPU:    0
May 15 21:18:17 Linux kernel: EIP:    0060:[<f899f418>]    Not tainted
May 15 21:18:17 Linux kernel: EFLAGS: 00010286
May 15 21:18:17 Linux kernel: 
May 15 21:18:17 Linux kernel: EIP is at reiserfs_panic [reiserfs] 0x38
(2.4.20-13.9smp)
May 15 21:18:17 Linux kernel: eax: 00000015   ebx: e7da0c00   ecx: c03ab0a8  
edx: ebd35f7c
May 15 21:18:17 Linux kernel: esi: f64dfc00   edi: e7da0c00   ebp: 00000000  
esp: df099dbc
May 15 21:18:17 Linux kernel: ds: 0068   es: 0068   ss: 0068
May 15 21:18:17 Linux kernel: Process mount (pid: 5796, stackpage=df099000)
May 15 21:18:17 Linux kernel: Stack: f89b7a90 f89bc240 df099e18 df099e18
f89ad226 e7da0c00 f89b7d7e 00000046 
May 15 21:18:17 Linux kernel:        df099e18 e7da0c00 00000000 00000001
00000000 df099e18 e7da0c00 00000000 
May 15 21:18:17 Linux kernel:        00000001 f89acd3d df099e18 e7da0c00
f64dfc00 ebd33f30 3ec38589 f89b7d76 
May 15 21:18:17 Linux kernel: Call Trace:   [<f89b7a90>] .rodata.str1.1
[reiserfs] 0x4ee (0xdf099dbc))
May 15 21:18:17 Linux kernel: [<f89bc240>] error_buf [reiserfs] 0x0 (0xdf099dc0))
May 15 21:18:17 Linux kernel: [<f89ad226>] journal_mark_dirty [reiserfs] 0x346
(0xdf099dcc))
May 15 21:18:17 Linux kernel: [<f89b7d7e>] .rodata.str1.1 [reiserfs] 0x7dc
(0xdf099dd4))
May 15 21:18:17 Linux kernel: [<f89acd3d>] do_journal_begin_r [reiserfs] 0x16d
(0xdf099e00))
May 15 21:18:17 Linux kernel: [<f89b7d76>] .rodata.str1.1 [reiserfs] 0x7d4
(0xdf099e18))
May 15 21:18:17 Linux kernel: [<f89aceb5>] journal_begin [reiserfs] 0x35
(0xdf099e48))
May 15 21:18:17 Linux kernel: [<f899e2d4>] reiserfs_read_super [reiserfs] 0x3f4
(0xdf099e5c))
May 15 21:18:17 Linux kernel: [<c0156cba>] alloc_super [kernel] 0x3a (0xdf099e9c))
May 15 21:18:17 Linux kernel: [<c01578df>] get_sb_bdev [kernel] 0x1bf (0xdf099eb0))
May 15 21:18:17 Linux kernel: [<c016cd5c>] alloc_vfsmnt [kernel] 0x9c (0xdf099ed8))
May 15 21:18:17 Linux kernel: [<f89bc050>] reiserfs_fs_type [reiserfs] 0x0
(0xdf099ef4))
May 15 21:18:17 Linux kernel: [<c0157c91>] do_kern_mount [kernel] 0x121
(0xdf099efc))
May 15 21:18:17 Linux kernel: [<f89bc050>] reiserfs_fs_type [reiserfs] 0x0
(0xdf099f00))
May 15 21:18:17 Linux kernel: [<c016e053>] do_add_mount [kernel] 0x93 (0xdf099f20))
May 15 21:18:17 Linux kernel: [<c016e365>] do_mount [kernel] 0x155 (0xdf099f40))
May 15 21:18:17 Linux kernel: [<c016e1b9>] copy_mount_options [kernel] 0x79
(0xdf099f70))
May 15 21:18:17 Linux kernel: [<c016e84c>] sys_mount [kernel] 0xdc (0xdf099f90))
May 15 21:18:17 Linux kernel: [<c010972f>] system_call [kernel] 0x33 (0xdf099fc0))
May 15 21:18:17 Linux kernel: 
May 15 21:18:17 Linux kernel: 
May 15 21:18:17 Linux kernel: Code: 0f 0b 4e 01 96 7a 9b f8 85 db 74 0e 0f b7 43
08 89 04 24 e8
Comment 1 Alan Cox 2003-06-08 07:51:15 EDT

*** This bug has been marked as a duplicate of 96974 ***
Comment 2 Red Hat Bugzilla 2006-02-21 13:56:37 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.