Bug 969731 - SELinux is preventing /usr/bin/ls from 'append' accesses on the file /home/user9/.config/teamviewer8/logfiles/startup.log.
SELinux is preventing /usr/bin/ls from 'append' accesses on the file /home/us...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
18
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:7b2129900ff8ee8b29ba139f815...
:
: 969732 969733 969734 969735 969736 969737 969738 969739 969740 969741 969742 969743 969744 969745 969746 969747 969748 969749 969750 969751 969752 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-02 01:36 EDT by Moez Roy
Modified: 2013-10-25 09:12 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-25 09:12:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Moez Roy 2013-06-02 01:36:32 EDT
Description of problem:
SELinux is preventing /usr/bin/ls from 'append' accesses on the file /home/user9/.config/teamviewer8/logfiles/startup.log.

*****  Plugin leaks (86.2 confidence) suggests  ******************************

If you want to ignore ls trying to append access the startup.log file, because you believe it should not need this access.
Then you should report this as a bug.  
You can generate a local policy module to dontaudit this access.
Do
# grep /usr/bin/ls /var/log/audit/audit.log | audit2allow -D -M mypol
# semodule -i mypol.pp

*****  Plugin catchall (14.7 confidence) suggests  ***************************

If you believe that ls should be allowed append access on the startup.log file by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# grep ls /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                system_u:system_r:initrc_t:s0
Target Context                unconfined_u:object_r:config_home_t:s0
Target Objects                /home/user9/.config/teamviewer8/logfiles/startup.l
                              og [ file ]
Source                        ls
Source Path                   /usr/bin/ls
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           coreutils-8.17-8.fc18.x86_64
Target RPM Packages           
Policy RPM                    selinux-policy-3.11.1-97.fc18.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Permissive
Host Name                     (removed)
Platform                      Linux (removed) 3.9.4-200.fc18.x86_64 #1 SMP Fri
                              May 24 20:10:49 UTC 2013 x86_64 x86_64
Alert Count                   1
First Seen                    2013-05-31 09:47:27 PDT
Last Seen                     2013-05-31 09:47:27 PDT
Local ID                      b12c22b0-294b-41fc-8018-1639361b1489

Raw Audit Messages
type=AVC msg=audit(1370018847.767:495): avc:  denied  { append } for  pid=11264 comm="ls" path="/home/user9/.config/teamviewer8/logfiles/startup.log" dev="dm-3" ino=45876364 scontext=system_u:system_r:initrc_t:s0 tcontext=unconfined_u:object_r:config_home_t:s0 tclass=file


type=SYSCALL msg=audit(1370018847.767:495): arch=x86_64 syscall=execve success=yes exit=0 a0=e67a60 a1=e33450 a2=e65570 a3=18 items=0 ppid=11249 pid=11264 auid=4294967295 uid=1000 gid=1000 euid=1000 suid=1000 fsuid=1000 egid=1000 sgid=1000 fsgid=1000 ses=4294967295 tty=(none) comm=ls exe=/usr/bin/ls subj=system_u:system_r:initrc_t:s0 key=(null)

Hash: ls,initrc_t,config_home_t,file,append

audit2allow

#============= initrc_t ==============
allow initrc_t config_home_t:file append;

audit2allow -R
require {
	type initrc_t;
}

#============= initrc_t ==============
gnome_manage_home_config(initrc_t)


Additional info:
reporter:       libreport-2.1.4
hashmarkername: setroubleshoot
kernel:         3.9.4-200.fc18.x86_64
type:           libreport
Comment 1 Miroslav Grepl 2013-06-03 02:01:54 EDT
Did you try to create an initial policy for

/opt/teamviewer8/tv_bin/teamviewerd

how I wrote in the previous bug from the last week?

I don't see a reason to report these bugs again.

Where does teamviewerd come from?
Comment 2 Miroslav Grepl 2013-06-03 02:03:57 EDT
Also 

# cat myunconfined.te
policy_module(myunconfined, 1.0)

require{
 type initrc_t
}

unconfined_module(initrc_t)



# make -f /usr/share/selinux/devel/Makefile mypol.pp
# semodule -i mypol.pp

will fix it for now.
Comment 3 Miroslav Grepl 2013-06-03 02:04:08 EDT
*** Bug 969732 has been marked as a duplicate of this bug. ***
Comment 4 Miroslav Grepl 2013-06-03 02:04:16 EDT
*** Bug 969733 has been marked as a duplicate of this bug. ***
Comment 5 Miroslav Grepl 2013-06-03 02:04:25 EDT
*** Bug 969734 has been marked as a duplicate of this bug. ***
Comment 6 Miroslav Grepl 2013-06-03 02:04:30 EDT
*** Bug 969735 has been marked as a duplicate of this bug. ***
Comment 7 Miroslav Grepl 2013-06-03 02:04:35 EDT
*** Bug 969736 has been marked as a duplicate of this bug. ***
Comment 8 Miroslav Grepl 2013-06-03 02:04:41 EDT
*** Bug 969737 has been marked as a duplicate of this bug. ***
Comment 9 Miroslav Grepl 2013-06-03 02:04:55 EDT
*** Bug 969738 has been marked as a duplicate of this bug. ***
Comment 10 Miroslav Grepl 2013-06-03 02:05:00 EDT
*** Bug 969739 has been marked as a duplicate of this bug. ***
Comment 11 Miroslav Grepl 2013-06-03 02:05:04 EDT
*** Bug 969740 has been marked as a duplicate of this bug. ***
Comment 12 Miroslav Grepl 2013-06-03 02:05:11 EDT
*** Bug 969741 has been marked as a duplicate of this bug. ***
Comment 13 Miroslav Grepl 2013-06-03 02:05:16 EDT
*** Bug 969743 has been marked as a duplicate of this bug. ***
Comment 14 Miroslav Grepl 2013-06-03 02:05:21 EDT
*** Bug 969742 has been marked as a duplicate of this bug. ***
Comment 15 Miroslav Grepl 2013-06-03 02:05:27 EDT
*** Bug 969744 has been marked as a duplicate of this bug. ***
Comment 16 Miroslav Grepl 2013-06-03 02:05:32 EDT
*** Bug 969745 has been marked as a duplicate of this bug. ***
Comment 17 Miroslav Grepl 2013-06-03 02:05:37 EDT
*** Bug 969746 has been marked as a duplicate of this bug. ***
Comment 18 Miroslav Grepl 2013-06-03 02:05:43 EDT
*** Bug 969747 has been marked as a duplicate of this bug. ***
Comment 19 Miroslav Grepl 2013-06-03 02:05:48 EDT
*** Bug 969748 has been marked as a duplicate of this bug. ***
Comment 20 Miroslav Grepl 2013-06-03 02:05:53 EDT
*** Bug 969749 has been marked as a duplicate of this bug. ***
Comment 21 Miroslav Grepl 2013-06-03 02:06:00 EDT
*** Bug 969750 has been marked as a duplicate of this bug. ***
Comment 22 Miroslav Grepl 2013-06-03 02:06:05 EDT
*** Bug 969751 has been marked as a duplicate of this bug. ***
Comment 23 Miroslav Grepl 2013-06-03 02:06:09 EDT
*** Bug 969752 has been marked as a duplicate of this bug. ***
Comment 24 Miroslav Grepl 2013-06-03 02:09:01 EDT
There is a bug in the local policy which I posted.

-unconfined_module(initrc_t)
+unconfined_domain(initrc_t)
Comment 25 Moez Roy 2013-06-03 21:06:19 EDT
(In reply to Miroslav Grepl from comment #1)
> Where does teamviewerd come from?

http://download.teamviewer.com/download/TeamViewer_Linux_PubKey.asc

http://download.teamviewer.com/download/teamviewer_linux.rpm
Comment 26 Lukas Vrabec 2013-10-25 09:12:43 EDT
#============= initrc_t ==============
#!!!! This avc is allowed in the current policy

allow initrc_t config_home_t:file append;

Note You need to log in before you can comment on or make changes to this bug.