Bug 969733 - SELinux is preventing /opt/teamviewer8/tv_bin/teamviewerd from 'name_connect' accesses on the tcp_socket .
SELinux is preventing /opt/teamviewer8/tv_bin/teamviewerd from 'name_connect'...
Status: CLOSED DUPLICATE of bug 969731
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
18
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:6f5497181eb924abdebfdbcab1c...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-02 01:40 EDT by Moez Roy
Modified: 2013-06-03 02:04 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-03 02:04:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Moez Roy 2013-06-02 01:40:11 EDT
Description of problem:
SELinux is preventing /opt/teamviewer8/tv_bin/teamviewerd from 'name_connect' accesses on the tcp_socket .

*****  Plugin catchall (100. confidence) suggests  ***************************

If you believe that teamviewerd should be allowed name_connect access on the  tcp_socket by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# grep KeepaliveThread /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                system_u:system_r:init_t:s0
Target Context                system_u:object_r:vnc_port_t:s0
Target Objects                 [ tcp_socket ]
Source                        KeepaliveThread
Source Path                   /opt/teamviewer8/tv_bin/teamviewerd
Port                          5938
Host                          (removed)
Source RPM Packages           teamviewer-8.0.17147-1.i686
Target RPM Packages           
Policy RPM                    selinux-policy-3.11.1-97.fc18.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Permissive
Host Name                     (removed)
Platform                      Linux (removed) 3.9.4-200.fc18.x86_64 #1 SMP Fri
                              May 24 20:10:49 UTC 2013 x86_64 x86_64
Alert Count                   2
First Seen                    2013-05-31 09:43:25 PDT
Last Seen                     2013-05-31 09:47:27 PDT
Local ID                      8ad85fd7-8229-4c81-8d42-3d9ac0b4ef69

Raw Audit Messages
type=AVC msg=audit(1370018847.606:488): avc:  denied  { name_connect } for  pid=11170 comm="TM_WaitAtGatewa" dest=5938 scontext=system_u:system_r:init_t:s0 tcontext=system_u:object_r:vnc_port_t:s0 tclass=tcp_socket


type=SYSCALL msg=audit(1370018847.606:488): arch=i386 syscall=getuid success=no exit=EINPROGRESS a0=3 a1=f49fded0 a2=20000 a3=0 items=0 ppid=1 pid=11170 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 ses=4294967295 tty=(none) comm=TM_WaitAtGatewa exe=/opt/teamviewer8/tv_bin/teamviewerd subj=system_u:system_r:init_t:s0 key=(null)

Hash: KeepaliveThread,init_t,vnc_port_t,tcp_socket,name_connect

audit2allow

#============= init_t ==============
allow init_t vnc_port_t:tcp_socket name_connect;

audit2allow -R
require {
	type init_t;
}

#============= init_t ==============
corenet_tcp_connect_vnc_port(init_t)


Additional info:
reporter:       libreport-2.1.4
hashmarkername: setroubleshoot
kernel:         3.9.4-200.fc18.x86_64
type:           libreport
Comment 1 Miroslav Grepl 2013-06-03 02:04:16 EDT

*** This bug has been marked as a duplicate of bug 969731 ***

Note You need to log in before you can comment on or make changes to this bug.