Bug 969736 - SELinux is preventing /usr/bin/cat from 'write' accesses on the file /home/user9/.config/teamviewer8/logfiles/startup.log.
SELinux is preventing /usr/bin/cat from 'write' accesses on the file /home/us...
Status: CLOSED DUPLICATE of bug 969731
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
18
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:7c8dc383e913d2d61b74b543298...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-02 01:42 EDT by Moez Roy
Modified: 2013-06-03 02:04 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-03 02:04:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Moez Roy 2013-06-02 01:42:07 EDT
Description of problem:
SELinux is preventing /usr/bin/cat from 'write' accesses on the file /home/user9/.config/teamviewer8/logfiles/startup.log.

*****  Plugin leaks (86.2 confidence) suggests  ******************************

If you want to ignore cat trying to write access the startup.log file, because you believe it should not need this access.
Then you should report this as a bug.  
You can generate a local policy module to dontaudit this access.
Do
# grep /usr/bin/cat /var/log/audit/audit.log | audit2allow -D -M mypol
# semodule -i mypol.pp

*****  Plugin catchall (14.7 confidence) suggests  ***************************

If you believe that cat should be allowed write access on the startup.log file by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# grep cat /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                system_u:system_r:initrc_t:s0
Target Context                unconfined_u:object_r:config_home_t:s0
Target Objects                /home/user9/.config/teamviewer8/logfiles/startup.l
                              og [ file ]
Source                        cat
Source Path                   /usr/bin/cat
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           coreutils-8.17-8.fc18.x86_64
Target RPM Packages           
Policy RPM                    selinux-policy-3.11.1-97.fc18.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Permissive
Host Name                     (removed)
Platform                      Linux (removed) 3.9.4-200.fc18.x86_64 #1 SMP Fri
                              May 24 20:10:49 UTC 2013 x86_64 x86_64
Alert Count                   1
First Seen                    2013-05-31 09:47:27 PDT
Last Seen                     2013-05-31 09:47:27 PDT
Local ID                      e103a9b7-afc5-413e-9d36-73d8807fd264

Raw Audit Messages
type=AVC msg=audit(1370018847.701:491): avc:  denied  { write } for  pid=11259 comm="cat" path="/home/user9/.config/teamviewer8/logfiles/startup.log" dev="dm-3" ino=45876364 scontext=system_u:system_r:initrc_t:s0 tcontext=unconfined_u:object_r:config_home_t:s0 tclass=file


type=SYSCALL msg=audit(1370018847.701:491): arch=x86_64 syscall=execve success=yes exit=0 a0=e36380 a1=e65290 a2=e65570 a3=18 items=0 ppid=11249 pid=11259 auid=4294967295 uid=1000 gid=1000 euid=1000 suid=1000 fsuid=1000 egid=1000 sgid=1000 fsgid=1000 ses=4294967295 tty=(none) comm=cat exe=/usr/bin/cat subj=system_u:system_r:initrc_t:s0 key=(null)

Hash: cat,initrc_t,config_home_t,file,write

audit2allow

#============= initrc_t ==============
allow initrc_t config_home_t:file write;

audit2allow -R
require {
	type initrc_t;
}

#============= initrc_t ==============
gnome_manage_home_config(initrc_t)


Additional info:
reporter:       libreport-2.1.4
hashmarkername: setroubleshoot
kernel:         3.9.4-200.fc18.x86_64
type:           libreport
Comment 1 Miroslav Grepl 2013-06-03 02:04:35 EDT

*** This bug has been marked as a duplicate of bug 969731 ***

Note You need to log in before you can comment on or make changes to this bug.