Bug 969741 - SELinux is preventing /opt/teamviewer8/tv_bin/wine/bin/wine from 'write' accesses on the file /home/user9/.config/teamviewer8/logfiles/winelogDesktop.
SELinux is preventing /opt/teamviewer8/tv_bin/wine/bin/wine from 'write' acce...
Status: CLOSED DUPLICATE of bug 969731
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
18
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:d703d4ac11adadf31f55af42d1b...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-02 01:45 EDT by Moez Roy
Modified: 2013-06-03 02:05 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-03 02:05:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Moez Roy 2013-06-02 01:45:06 EDT
Description of problem:
SELinux is preventing /opt/teamviewer8/tv_bin/wine/bin/wine from 'write' accesses on the file /home/user9/.config/teamviewer8/logfiles/winelogDesktop.

*****  Plugin leaks (86.2 confidence) suggests  ******************************

If you want to ignore wine trying to write access the winelogDesktop file, because you believe it should not need this access.
Then you should report this as a bug.  
You can generate a local policy module to dontaudit this access.
Do
# grep /opt/teamviewer8/tv_bin/wine/bin/wine /var/log/audit/audit.log | audit2allow -D -M mypol
# semodule -i mypol.pp

*****  Plugin catchall (14.7 confidence) suggests  ***************************

If you believe that wine should be allowed write access on the winelogDesktop file by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# grep wine /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                system_u:system_r:initrc_t:s0
Target Context                system_u:object_r:config_home_t:s0
Target Objects                /home/user9/.config/teamviewer8/logfiles/winelogDe
                              sktop [ file ]
Source                        wine
Source Path                   /opt/teamviewer8/tv_bin/wine/bin/wine
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           teamviewer-8.0.17147-1.i686
Target RPM Packages           
Policy RPM                    selinux-policy-3.11.1-97.fc18.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Permissive
Host Name                     (removed)
Platform                      Linux (removed) 3.9.4-200.fc18.x86_64 #1 SMP Fri
                              May 24 20:10:49 UTC 2013 x86_64 x86_64
Alert Count                   1
First Seen                    2013-05-31 09:47:27 PDT
Last Seen                     2013-05-31 09:47:27 PDT
Local ID                      80832628-a0b3-49a0-89c2-5da98da10dce

Raw Audit Messages
type=AVC msg=audit(1370018847.775:498): avc:  denied  { write } for  pid=11249 comm="wine" path="/home/user9/.config/teamviewer8/logfiles/winelogDesktop" dev="dm-3" ino=45876491 scontext=system_u:system_r:initrc_t:s0 tcontext=system_u:object_r:config_home_t:s0 tclass=file


type=SYSCALL msg=audit(1370018847.775:498): arch=x86_64 syscall=execve success=yes exit=0 a0=e4e0a0 a1=e60430 a2=e35d50 a3=8 items=0 ppid=11097 pid=11249 auid=4294967295 uid=1000 gid=1000 euid=1000 suid=1000 fsuid=1000 egid=1000 sgid=1000 fsgid=1000 ses=4294967295 tty=(none) comm=wine exe=/opt/teamviewer8/tv_bin/wine/bin/wine subj=system_u:system_r:initrc_t:s0 key=(null)

Hash: wine,initrc_t,config_home_t,file,write

audit2allow

#============= initrc_t ==============
allow initrc_t config_home_t:file write;

audit2allow -R
require {
	type initrc_t;
}

#============= initrc_t ==============
gnome_manage_home_config(initrc_t)


Additional info:
reporter:       libreport-2.1.4
hashmarkername: setroubleshoot
kernel:         3.9.4-200.fc18.x86_64
type:           libreport
Comment 1 Miroslav Grepl 2013-06-03 02:05:11 EDT

*** This bug has been marked as a duplicate of bug 969731 ***

Note You need to log in before you can comment on or make changes to this bug.