Bug 969742 - SELinux is preventing /opt/teamviewer8/tv_bin/wine/bin/wine-preloader from using the 'execmem' accesses on a process.
SELinux is preventing /opt/teamviewer8/tv_bin/wine/bin/wine-preloader from us...
Status: CLOSED DUPLICATE of bug 969731
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
18
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:56491f0589677b5db417159aad0...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-02 01:46 EDT by Moez Roy
Modified: 2013-06-03 02:05 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-03 02:05:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Moez Roy 2013-06-02 01:46:44 EDT
Description of problem:
SELinux is preventing /opt/teamviewer8/tv_bin/wine/bin/wine-preloader from using the 'execmem' accesses on a process.

*****  Plugin catchall (100. confidence) suggests  ***************************

If you believe that wine-preloader should be allowed execmem access on processes labeled initrc_t by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# grep wine-preloader /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                system_u:system_r:initrc_t:s0
Target Context                system_u:system_r:initrc_t:s0
Target Objects                 [ process ]
Source                        wine-preloader
Source Path                   /opt/teamviewer8/tv_bin/wine/bin/wine-preloader
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           teamviewer-8.0.17147-1.i686
Target RPM Packages           
Policy RPM                    selinux-policy-3.11.1-97.fc18.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Permissive
Host Name                     (removed)
Platform                      Linux (removed) 3.9.4-200.fc18.x86_64 #1 SMP Fri
                              May 24 20:10:49 UTC 2013 x86_64 x86_64
Alert Count                   1
First Seen                    2013-05-31 09:47:27 PDT
Last Seen                     2013-05-31 09:47:27 PDT
Local ID                      cb57bb50-58b5-4bf2-b993-0b877d712531

Raw Audit Messages
type=AVC msg=audit(1370018847.776:500): avc:  denied  { execmem } for  pid=11249 comm="wine-preloader" scontext=system_u:system_r:initrc_t:s0 tcontext=system_u:system_r:initrc_t:s0 tclass=process


type=SYSCALL msg=audit(1370018847.776:500): arch=i386 syscall=capget success=yes exit=0 a0=7ffff000 a1=1000 a2=5 a3=7ffff000 items=0 ppid=11097 pid=11249 auid=4294967295 uid=1000 gid=1000 euid=1000 suid=1000 fsuid=1000 egid=1000 sgid=1000 fsgid=1000 ses=4294967295 tty=(none) comm=wine-preloader exe=/opt/teamviewer8/tv_bin/wine/bin/wine-preloader subj=system_u:system_r:initrc_t:s0 key=(null)

Hash: wine-preloader,initrc_t,initrc_t,process,execmem

audit2allow

#============= initrc_t ==============
allow initrc_t self:process execmem;

audit2allow -R
require {
	type initrc_t;
	class process execmem;
}

#============= initrc_t ==============
allow initrc_t self:process execmem;


Additional info:
reporter:       libreport-2.1.4
hashmarkername: setroubleshoot
kernel:         3.9.4-200.fc18.x86_64
type:           libreport
Comment 1 Miroslav Grepl 2013-06-03 02:05:21 EDT

*** This bug has been marked as a duplicate of bug 969731 ***

Note You need to log in before you can comment on or make changes to this bug.