Bug 969743 - SELinux is preventing /opt/teamviewer8/tv_bin/wine/bin/wine-preloader from 'write' accesses on the sock_file socket.
SELinux is preventing /opt/teamviewer8/tv_bin/wine/bin/wine-preloader from 'w...
Status: CLOSED DUPLICATE of bug 969731
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
18
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:ff3b20fe2793689f97d8bbce23f...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-02 01:47 EDT by Moez Roy
Modified: 2013-06-03 02:05 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-03 02:05:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Moez Roy 2013-06-02 01:47:16 EDT
Description of problem:
SELinux is preventing /opt/teamviewer8/tv_bin/wine/bin/wine-preloader from 'write' accesses on the sock_file socket.

*****  Plugin catchall (100. confidence) suggests  ***************************

If you believe that wine-preloader should be allowed write access on the socket sock_file by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# grep wine /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                system_u:system_r:initrc_t:s0
Target Context                unconfined_u:object_r:user_tmp_t:s0
Target Objects                socket [ sock_file ]
Source                        wine
Source Path                   /opt/teamviewer8/tv_bin/wine/bin/wine-preloader
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           teamviewer-8.0.17147-1.i686
Target RPM Packages           
Policy RPM                    selinux-policy-3.11.1-97.fc18.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Permissive
Host Name                     (removed)
Platform                      Linux (removed) 3.9.4-200.fc18.x86_64 #1 SMP Fri
                              May 24 20:10:49 UTC 2013 x86_64 x86_64
Alert Count                   1
First Seen                    2013-05-31 09:47:27 PDT
Last Seen                     2013-05-31 09:47:27 PDT
Local ID                      dce526c5-7441-4fe8-9551-ff57e217efd4

Raw Audit Messages
type=AVC msg=audit(1370018847.777:501): avc:  denied  { write } for  pid=11249 comm="wine" name="socket" dev="tmpfs" ino=195446 scontext=system_u:system_r:initrc_t:s0 tcontext=unconfined_u:object_r:user_tmp_t:s0 tclass=sock_file


type=AVC msg=audit(1370018847.777:501): avc:  denied  { connectto } for  pid=11249 comm="wine" path="/tmp/.wine-1000/server-fd03-2bc047e/socket" scontext=system_u:system_r:initrc_t:s0 tcontext=unconfined_u:unconfined_r:unconfined_t:s0-s0:c0.c1023 tclass=unix_stream_socket


type=SYSCALL msg=audit(1370018847.777:501): arch=i386 syscall=getuid success=yes exit=0 a0=3 a1=ff80cea0 a2=7bc93454 a3=7db4d4a8 items=0 ppid=11097 pid=11249 auid=4294967295 uid=1000 gid=1000 euid=1000 suid=1000 fsuid=1000 egid=1000 sgid=1000 fsgid=1000 ses=4294967295 tty=(none) comm=wine exe=/opt/teamviewer8/tv_bin/wine/bin/wine-preloader subj=system_u:system_r:initrc_t:s0 key=(null)

Hash: wine,initrc_t,user_tmp_t,sock_file,write

audit2allow

#============= initrc_t ==============
allow initrc_t unconfined_t:unix_stream_socket connectto;
allow initrc_t user_tmp_t:sock_file write;

audit2allow -R
require {
	type initrc_t;
}

#============= initrc_t ==============
unconfined_stream_connect(initrc_t)
userdom_stream_connect(initrc_t)


Additional info:
reporter:       libreport-2.1.4
hashmarkername: setroubleshoot
kernel:         3.9.4-200.fc18.x86_64
type:           libreport
Comment 1 Miroslav Grepl 2013-06-03 02:05:16 EDT

*** This bug has been marked as a duplicate of bug 969731 ***

Note You need to log in before you can comment on or make changes to this bug.