Bug 969752 - SELinux is preventing /opt/teamviewer8/tv_bin/wine/bin/wine-preloader from 'write' accesses on the directory /home/user9/.config/teamviewer8/config.
SELinux is preventing /opt/teamviewer8/tv_bin/wine/bin/wine-preloader from 'w...
Status: CLOSED DUPLICATE of bug 969731
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
18
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:c7ac6cf1c90b20f47e034f581a7...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-02 01:51 EDT by Moez Roy
Modified: 2013-06-03 02:06 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-03 02:06:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Moez Roy 2013-06-02 01:51:13 EDT
Description of problem:
SELinux is preventing /opt/teamviewer8/tv_bin/wine/bin/wine-preloader from 'write' accesses on the directory /home/user9/.config/teamviewer8/config.

*****  Plugin catchall (100. confidence) suggests  ***************************

If you believe that wine-preloader should be allowed write access on the config directory by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# grep TeamViewer_Desk /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                system_u:system_r:initrc_t:s0
Target Context                unconfined_u:object_r:config_home_t:s0
Target Objects                /home/user9/.config/teamviewer8/config [ dir ]
Source                        TeamViewer_Desk
Source Path                   /opt/teamviewer8/tv_bin/wine/bin/wine-preloader
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           teamviewer-8.0.17147-1.i686
Target RPM Packages           
Policy RPM                    selinux-policy-3.11.1-97.fc18.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Permissive
Host Name                     (removed)
Platform                      Linux (removed) 3.9.4-200.fc18.x86_64 #1 SMP Fri
                              May 24 20:10:49 UTC 2013 x86_64 x86_64
Alert Count                   1
First Seen                    2013-05-31 09:48:35 PDT
Last Seen                     2013-05-31 09:48:35 PDT
Local ID                      fc7e9075-79b0-4a3d-b268-cdfd733a5f89

Raw Audit Messages
type=AVC msg=audit(1370018915.52:514): avc:  denied  { write } for  pid=11249 comm="TeamViewer_Desk" name="config" dev="dm-3" ino=46006298 scontext=system_u:system_r:initrc_t:s0 tcontext=unconfined_u:object_r:config_home_t:s0 tclass=dir


type=AVC msg=audit(1370018915.52:514): avc:  denied  { remove_name } for  pid=11249 comm="TeamViewer_Desk" name="client.conf_" dev="dm-3" ino=46006304 scontext=system_u:system_r:initrc_t:s0 tcontext=unconfined_u:object_r:config_home_t:s0 tclass=dir


type=AVC msg=audit(1370018915.52:514): avc:  denied  { rename } for  pid=11249 comm="TeamViewer_Desk" name="client.conf_" dev="dm-3" ino=46006304 scontext=system_u:system_r:initrc_t:s0 tcontext=unconfined_u:object_r:config_home_t:s0 tclass=file


type=AVC msg=audit(1370018915.52:514): avc:  denied  { add_name } for  pid=11249 comm="TeamViewer_Desk" name="client.conf" dev="dm-3" ino=46006302 scontext=system_u:system_r:initrc_t:s0 tcontext=unconfined_u:object_r:config_home_t:s0 tclass=dir


type=AVC msg=audit(1370018915.52:514): avc:  denied  { unlink } for  pid=11249 comm="TeamViewer_Desk" name="client.conf" dev="dm-3" ino=46006302 scontext=system_u:system_r:initrc_t:s0 tcontext=system_u:object_r:config_home_t:s0 tclass=file


type=SYSCALL msg=audit(1370018915.52:514): arch=i386 syscall=setitimer success=yes exit=0 a0=198420 a1=19d9e0 a2=7b88cb34 a3=0 items=0 ppid=11097 pid=11249 auid=4294967295 uid=1000 gid=1000 euid=1000 suid=1000 fsuid=1000 egid=1000 sgid=1000 fsgid=1000 ses=4294967295 tty=(none) comm=TeamViewer_Desk exe=/opt/teamviewer8/tv_bin/wine/bin/wine-preloader subj=system_u:system_r:initrc_t:s0 key=(null)

Hash: TeamViewer_Desk,initrc_t,config_home_t,dir,write

audit2allow

#============= initrc_t ==============
allow initrc_t config_home_t:dir { write remove_name add_name };
allow initrc_t config_home_t:file { rename unlink };

audit2allow -R
require {
	type initrc_t;
}

#============= initrc_t ==============
gnome_manage_home_config(initrc_t)
gnome_manage_home_config_dirs(initrc_t)


Additional info:
reporter:       libreport-2.1.4
hashmarkername: setroubleshoot
kernel:         3.9.4-200.fc18.x86_64
type:           libreport
Comment 1 Miroslav Grepl 2013-06-03 02:06:09 EDT

*** This bug has been marked as a duplicate of bug 969731 ***

Note You need to log in before you can comment on or make changes to this bug.