Bug 969759 - Failed create a first iSCSI Storage Domain, because host hold iSCSI session to old targets
Failed create a first iSCSI Storage Domain, because host hold iSCSI session t...
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
3.2.0
x86_64 Linux
unspecified Severity high
: ---
: 3.3.0
Assigned To: Nobody's working on this, feel free to take it
vvyazmin@redhat.com
storage
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-02 04:36 EDT by vvyazmin@redhat.com
Modified: 2016-02-10 12:46 EST (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-03 06:54:23 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
## Logs rhevm, vdsm, libvirt, thread dump, superVdsm (3.47 MB, application/x-gzip)
2013-06-02 04:36 EDT, vvyazmin@redhat.com
no flags Details

  None (edit)
Description vvyazmin@redhat.com 2013-06-02 04:36:22 EDT
Created attachment 755767 [details]
## Logs rhevm, vdsm, libvirt, thread dump, superVdsm

Description of problem: Failed create a first iSCSI Storage Domain, because host hold iSCSI session to old targets

Version-Release number of selected component (if applicable):
RHEVM 3.2 - SF17.1 environment: 

RHEVM: rhevm-3.2.0-11.28.el6ev.noarch 
VDSM: vdsm-4.10.2-21.0.el6ev.x86_64 
LIBVIRT: libvirt-0.10.2-18.el6_4.5.x86_64 
QEMU & KVM: qemu-kvm-rhev-0.12.1.2-2.355.el6_4.3.x86_64 
SANLOCK: sanlock-2.6-2.el6.x86_64

How reproducible:
100%

Depend on BZ969756

Steps to Reproduce:
1. Create iSCSI DC with 50 hosts (in my case 50 fake hosts) connected to 9 Storage Domain, when each one consisted of 8 PV's 
2. All host in “up” state, and all SD in “Active” state
3. Maintenance all 50 hosts (no problem with thread are found)
4. All host in “Maintenance” state
5. Attached all hosts to new iSCSI DC
6. Activate all host
7. All host in “up” state
8. Try create a first SD
  
Actual results:
Failed create first SD.
This happens because, in step 3, some hosts (on 6 from 50) hold iSCSI session to old targets

Expected results:
1. Succeed create first SD
2. Block create  first SD action some host hold iSCSI session to old targets
3. Get warning message in UI, and logs

Impact on user:

Workaround:
Manually disconnect from iSCSI target
    iscsiadm -m session -u
    iscsiadm -m node -o delete

Additional info:

/var/log/ovirt-engine/engine.log

/var/log/vdsm/vdsm.log
Comment 2 vvyazmin@redhat.com 2013-06-03 06:54:23 EDT
I will close this bug, because there is already existing a bug with root cause to this issue.

Note You need to log in before you can comment on or make changes to this bug.