Bug 969774 - [abrt] BUG: unable to handle kernel NULL pointer dereference at 00000014
[abrt] BUG: unable to handle kernel NULL pointer dereference at 00000014
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
18
i686 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
abrt_hash:7c37c195b676771212d7be1a2c3...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-02 06:00 EDT by Momed
Modified: 2013-10-25 17:14 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-25 17:14:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: dmesg (77.37 KB, text/plain)
2013-06-02 06:01 EDT, Momed
no flags Details
dmesg log (69.84 KB, text/x-log)
2013-07-03 11:08 EDT, Momed
no flags Details

  None (edit)
Description Momed 2013-06-02 06:00:35 EDT
Additional info:
reporter:       libreport-2.1.4
BUG: unable to handle kernel NULL pointer dereference at 00000014
IP: [<c0704bf3>] acpi_ps_has_completed_scope+0xb/0x25
*pde = 00000000 
Oops: 0000 [#1] SMP 
Modules linked in: option usb_wwan usb_storage ipt_MASQUERADE nf_conntrack_netbios_ns nf_conntrack_broadcast ip6table_mangle ip6t_REJECT nf_conntrack_ipv6 nf_defrag_ipv6 iptable_nat nf_nat_ipv4 nf_nat be2iscsi iptable_mangle iscsi_boot_sysfs bnx2i cnic nf_conntrack_ipv4 nf_defrag_ipv4 xt_conntrack uio cxgb4i cxgb4 nf_conntrack cxgb3i ebtable_filter cxgb3 mdio ebtables libcxgbi ib_iser rdma_cm ib_addr iw_cm ib_cm ip6table_filter ib_sa ib_mad ib_core ip6_tables iscsi_tcp libiscsi_tcp libiscsi scsi_transport_iscsi rfcomm bnep ppdev snd_hda_codec_analog acpi_cpufreq arc4 iwl3945 iwlegacy parport_pc mac80211 mperf snd_hda_intel coretemp snd_hda_codec btusb kvm_intel bluetooth iTCO_wdt kvm snd_hwdep hp_wmi cfg80211 snd_seq snd_seq_device snd_pcm iTCO_vendor_support tpm_tis snd_page_alloc snd_timer snd sparse_keymap microcode lpc_ich parport joydev tpm_infineon soundcore rfkill serio_raw hp_accel lis3lv02d tpm tpm_bios input_polldev uinput binfmt_misc i915 i2c_algo_bit firewire_ohci drm_kms_helper drm firewire_core yenta_socket crc_itu_t i2c_core wmi video sunrpc
Pid: 1210, comm: upowerd Not tainted 3.9.4-200.fc18.i686 #1 Hewlett-Packard HP Compaq 6710b/30C0
EIP: 0060:[<c0704bf3>] EFLAGS: 00010202 CPU: 0
EIP is at acpi_ps_has_completed_scope+0xb/0x25
EAX: eb6d7028 EBX: eb6d7000 ECX: 00003fb2 EDX: 00000000
ESI: eb6d7000 EDI: eb6d7000 EBP: f2273dac ESP: f2273dac
 DS: 007b ES: 007b FS: 00d8 GS: 00e0 SS: 0068
CR0: 80050033 CR2: 00000014 CR3: 32218000 CR4: 000007d0
DR0: 00000000 DR1: 00000000 DR2: 00000000 DR3: 00000000
DR6: ffff0ff0 DR7: 00000400
Process upowerd (pid: 1210, ti=f2272000 task=f369d940 task.ti=f2272000)
Stack:
 f2273df4 c0703bf0 00000001 c06f4fe9 f697ba80 f3c01580 00003fb2 eb6d7000
 eb6d7000 eb6d7000 eb6d7028 f2273df4 c06f4fe9 00000000 c06f1f53 00000000
 eb6d7000 eb6d7000 f2273e1c c0704a1c eea0e820 00000000 00000000 00000000
Call Trace:
 [<c0703bf0>] acpi_ps_parse_loop+0x44/0x4f4
 [<c06f4fe9>] ? acpi_ds_delete_walk_state+0xc1/0xc8
 [<c06f4fe9>] ? acpi_ds_delete_walk_state+0xc1/0xc8
 [<c06f1f53>] ? acpi_ds_restart_control_method+0x4c/0x64
 [<c0704a1c>] acpi_ps_parse_aml+0x87/0x243
 [<c070518d>] acpi_ps_execute_method+0x1a1/0x240
 [<c0700059>] acpi_ns_evaluate+0xb1/0x190
 [<c0702b3b>] acpi_evaluate_object+0xf2/0x1e6
 [<c0711c86>] acpi_battery_get_state+0x5d/0x17f
 [<c0711dce>] acpi_battery_get_property+0x26/0x27a
 [<c082937a>] power_supply_show_property+0x4a/0x1d0
 [<c0829330>] ? power_supply_store_property+0x60/0x60
 [<c075cc2f>] dev_attr_show+0x1f/0x50
 [<c05aad05>] sysfs_read_file+0x85/0x160
 [<c054a76a>] ? rw_verify_area+0x5a/0x110
 [<c05aac80>] ? sysfs_write_file+0xf0/0xf0
 [<c054aa09>] vfs_read+0x89/0x160
 [<c05aac80>] ? sysfs_write_file+0xf0/0xf0
 [<c054ac57>] sys_read+0x47/0x80
 [<c099344d>] sysenter_do_call+0x12/0x28
Code: 04 00 00 00 83 c4 14 89 d8 5b 5e 5f 5d c3 66 90 55 89 e5 66 66 66 66 90 8b 40 1c 5d 8b 40 10 c3 55 89 e5 66 66 66 66 90 8b 50 1c <8b> 4a 14 39 48 04 73 0b 31 c0 83 7a 0c 00 0f 94 c0 eb 05 b8 01
EIP: [<c0704bf3>] acpi_ps_has_completed_scope+0xb/0x25 SS:ESP 0068:f2273dac
CR2: 0000000000000014
Comment 1 Momed 2013-06-02 06:01:38 EDT
Created attachment 755793 [details]
File: dmesg
Comment 2 Josh Boyer 2013-07-01 14:38:53 EDT
A bluetooth device seems to have timed out, causing the acpi calls to get the battery to oops.  We've included a patch in the latest F18 update that deals with bluetooth battery issues.  Can you see if that resolves your problem?
Comment 3 Momed 2013-07-02 15:55:17 EDT
(In reply to Josh Boyer from comment #2)
> A bluetooth device seems to have timed out, causing the acpi calls to get
> the battery to oops.  We've included a patch in the latest F18 update that
> deals with bluetooth battery issues.  Can you see if that resolves your
> problem?

No, as far as I can see, each time I connect an external usb bluetooth dongle, it causes an error whenever I try to send or receive a file using bluetooth, it happens again. But bugzilla claims the kernel is tainted so it cannot be reported.
Comment 4 Josh Boyer 2013-07-03 07:33:13 EDT
Can you attach the oops output here anyway?  You should be able to get it from dmesg.  Just do a fresh boot and then whatever you do to cause the oops.
Comment 5 Momed 2013-07-03 08:19:46 EDT
Well, whenever I transfer a file using the external bluetooth the whole system seems to freeze, and the screen is blank (black). It seems like the device somehow forces the screen to shutdown, and I'm unable to do anything except a forced shutdown.
Comment 6 Momed 2013-07-03 11:08:39 EDT
Created attachment 768258 [details]
dmesg log
Comment 7 Justin M. Forbes 2013-10-18 17:17:36 EDT
*********** MASS BUG UPDATE **************

We apologize for the inconvenience.  There is a large number of bugs to go through and several of them have gone stale.  Due to this, we are doing a mass bug update across all of the Fedora 18 kernel bugs.

Fedora 18 has now been rebased to 3.11.4-101.fc18.  Please test this kernel update (or newer) and let us know if you issue has been resolved or if it is still present with the newer kernel.

If you have moved on to Fedora 19, and are still experiencing this issue, please change the version to Fedora 19.

If you experience different issues, please open a new bug report for those.
Comment 8 Momed 2013-10-25 17:08:10 EDT
Hi, I think its fixed, it doesn't seem to crop up anymore. Thanks.

Note You need to log in before you can comment on or make changes to this bug.