Bug 969790 - DeprecationWarning when running certain cinder commands [NEEDINFO]
DeprecationWarning when running certain cinder commands
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-cinderclient (Show other bugs)
2.1
Unspecified Unspecified
medium Severity medium
: beta
: 4.0
Assigned To: Jakub Ruzicka
Giulio Fidente
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-02 07:32 EDT by Daniel Paikov
Modified: 2016-04-26 10:06 EDT (History)
7 users (show)

See Also:
Fixed In Version: python-cinderclient-1.0.6-2.el6ost
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-19 19:03:55 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
mlopes: needinfo? (jruzicka)


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenStack gerrit 50757 None None None Never

  None (edit)
Description Daniel Paikov 2013-06-02 07:32:35 EDT
Certain cinder commands that result in failure (for example, cinder show with a non-existant volume) produce the following python error:

[root@orange-vdsf ~(keystone_admin)]# cinder show 1
/usr/lib/python2.6/site-packages/cinderclient/shell.py:507: DeprecationWarning: BaseException.message has been deprecated as of Python 2.6
  message = e.message
ERROR: No volume with a name or ID of '1' exists.
Comment 2 Eric Harney 2013-06-03 16:20:10 EDT
To clarify, it's a warning, and not an error.
Comment 4 Eric Harney 2013-09-17 10:51:01 EDT
Only happens on Python 2.6 (RHOS).
Comment 5 Eric Harney 2013-10-09 17:24:03 EDT
Test case:

# unset OS_USERNAME
# cinder list
/usr/lib/python2.6/site-packages/cinderclient/shell.py:524: DeprecationWarning: BaseException.message has been deprecated as of Python 2.6
  message = e.message
ERROR: You must provide a username via either --os-username or env[OS_USERNAME]
# nova list
ERROR: You must provide a username via either --os-username or env[OS_USERNAME]
Comment 7 Jakub Ruzicka 2013-10-24 08:52:34 EDT
Fix backported to stable/havana.
Comment 9 Scott Lewis 2013-11-19 11:54:59 EST
Auto adding >= MODIFIED bugs to beta
Comment 10 Giulio Fidente 2013-11-20 07:48:05 EST
verified against python-cinderclient-1.0.6-2.el6ost
Comment 13 errata-xmlrpc 2013-12-19 19:03:55 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2013-1859.html

Note You need to log in before you can comment on or make changes to this bug.