Bug 969802 - has plymouth files
has plymouth files
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: dracut (Show other bugs)
18
Unspecified Linux
unspecified Severity medium
: ---
: ---
Assigned To: dracut-maint
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-02 08:16 EDT by udo
Modified: 2013-06-03 11:54 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-03 11:03:23 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description udo 2013-06-02 08:16:13 EDT
Description of problem:
dractut rpm has plymouth files

Version-Release number of selected component (if applicable):
dracut-024-25.git20130205.fc18.x86_64

How reproducible:
rpm -ql dracut-024-25.git20130205.fc18.x86_64|grep plymouth

Actual results:
plymouth files

Expected results:
plymouth files in plymouth rpms

Additional info:
Comment 1 Harald Hoyer 2013-06-03 04:47:31 EDT
?
Comment 2 udo 2013-06-03 09:21:57 EDT
# rpm -ql dracut|grep plym
/usr/lib/dracut/modules.d/50plymouth
/usr/lib/dracut/modules.d/50plymouth/module-setup.sh
/usr/lib/dracut/modules.d/50plymouth/plymouth-emergency.sh
/usr/lib/dracut/modules.d/50plymouth/plymouth-newroot.sh
/usr/lib/dracut/modules.d/50plymouth/plymouth-populate-initrd.sh
/usr/lib/dracut/modules.d/50plymouth/plymouth-pretrigger.sh


I do not want plymouth.
I expect dracut to be clean of plymouth files.

Same for systemd and same for fedora-logos (although they have some trademark/copyright excuse I do not understand).
Comment 3 Harald Hoyer 2013-06-03 11:03:23 EDT
If plymouth is not installed, /usr/lib/dracut/modules.d/50plymouth/module-setup.sh does not install anything for plymouth in your initrd.
Comment 4 udo 2013-06-03 11:13:00 EDT
Sure, but WHY OH WHY did they not include plymouth related fules with plymouth*rpm files?
Currently plymouth stuff is ALL OVER the place:

plymouth*rpm
fedora-logos
systemd
dracut

Looks highly untidy to me.

This is in the corner of a distro that is tidy, modular and allows choice of what to install and what not to install.
plymouth is just messy.
PackageKit and NetworkManager are dependency-hell.

So please start with the easy stuff and please put the files where they belong.
Comment 5 Harald Hoyer 2013-06-03 11:23:23 EDT
Because things worked differently if plymouth was used in the initramfs, special handling in dracut had to be done.
Comment 6 udo 2013-06-03 11:54:33 EDT
That is the runtime situation. It matters where the files are coming from, from the rpm perspective.
plymouth stuff belongs to a plymouth-* rpm and does have no place elsewhere.
Why is that so hard to understand?

Note You need to log in before you can comment on or make changes to this bug.