Bug 969872 - Custom cartridge without 'embedded' is not added to an app correctly
Custom cartridge without 'embedded' is not added to an app correctly
Status: CLOSED NOTABUG
Product: OpenShift Online
Classification: Red Hat
Component: Pod (Show other bugs)
2.x
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Rajat Chopra
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-02 16:32 EDT by Clayton Coleman
Modified: 2015-05-14 20:17 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-03 11:06:05 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Clayton Coleman 2013-06-02 16:32:50 EDT
A custom, non embedded (does not support embedding) DB cartridge can be installed to a non-scaled app, but does not deploy a new gear (or an embedded gear).

rhc create-app foo php-5.3
rhc add-cartridge "http://cartreflect-claytondev.rhcloud.com/reflect?github=smarterclayton/openshift-redis-cart&commit=no_embedded"

Broker reports success, but the redis cart is colocated with PHP (despite not having 'embedded'). SSH to main gear and there is no "redis" dir, which means that the install logic failed.

The cartridge cannot be removed because of bug 969724.

Should probably not block sprint exit, workaround is to add the 'embedded' tag.  Long term we want to disable embedded, so we want folks to not have to set it on their carts to function properly.
Comment 1 Rajat Chopra 2013-06-03 02:03:04 EDT
The keyword 'embedded' holds no significance to the broker. If it is a non-scalable app, the broker forces all cartridges to be located on one gear.

Note You need to log in before you can comment on or make changes to this bug.