Bug 969880 - [abrt] yum-3.2.29-40.el6: codecs.py:351:write:UnicodeDecodeError: 'ascii' codec can't decode byte 0xc5 in position 33: ordinal not in range(128)
[abrt] yum-3.2.29-40.el6: codecs.py:351:write:UnicodeDecodeError: 'ascii' cod...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: yum (Show other bugs)
6.4
x86_64 Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: packaging-team-maint
Karel Srot
abrt_hash:d8977989f3fe5668632c3bbb4a4...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-02 17:50 EDT by David Jaša
Modified: 2014-10-14 00:36 EDT (History)
5 users (show)

See Also:
Fixed In Version: yum-3.2.29-51.el6
Doc Type: Bug Fix
Doc Text:
NO DOCS NEEDED
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-10-14 00:36:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Jaša 2013-06-02 17:50:31 EDT
Version-Release number of selected component:
yum-3.2.29-40.el6

Additional info:
libreport version: 2.0.9
abrt_version:   2.0.8
cmdline:        /usr/bin/python /usr/bin/yum --nogpg --skip-broken upgrade evolution*
kernel:         2.6.32-358.6.1.el6.x86_64

backtrace:
:codecs.py:351:write:UnicodeDecodeError: 'ascii' codec can't decode byte 0xc5 in position 33: ordinal not in range(128)
:
:Traceback (most recent call last):
:  File "/usr/bin/yum", line 29, in <module>
:    yummain.user_main(sys.argv[1:], exit_code=True)
:  File "/usr/share/yum-cli/yummain.py", line 285, in user_main
:    errcode = main(args)
:  File "/usr/share/yum-cli/yummain.py", line 219, in main
:    return_code = base.doTransaction()
:  File "/usr/share/yum-cli/cli.py", line 530, in doTransaction
:    print to_utf8(msg)
:  File "/usr/lib64/python2.6/codecs.py", line 351, in write
:    data, consumed = self.encode(object, self.errors)
:UnicodeDecodeError: 'ascii' codec can't decode byte 0xc5 in position 33: ordinal not in range(128)
:
:Local variables in innermost frame:
:self: <open file '<stdout>', mode 'w' at 0x7fd1f9bbc150>
:object: 'libebook-1.2.so.9()(64bit) je pot\xc5\x99eba pro pidgin-2.10.6-3.el6.x86_64'
Comment 1 Zdeněk Pavlas 2013-06-03 04:17:20 EDT
Yum installs sys.stdout handler that correctly translates clean ascii or unicode strings, but fails on utf8.. this particular user tries to output utf8..  Has been fixed upstream with:

commit 74d21178642387998245f49d47353f3f5a84aef2
Author: Zdeněk Pavlas <zpavlas@redhat.com>
Date:   Mon Apr 2 11:24:09 2012 +0200

    sys.stdout: encode unicode strings only.  BZ 807619.
    
    Avoid codecs.getwriter() as it's not compatible with
    already encoded strings.
Comment 8 errata-xmlrpc 2014-10-14 00:36:31 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1410.html

Note You need to log in before you can comment on or make changes to this bug.