Bug 969890 - Oracle service do not check the mount point status and give wrong status during start / restart
Summary: Oracle service do not check the mount point status and give wrong status duri...
Status: CLOSED DEFERRED
Alias: None
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Other   
(Show other bugs)
Version: 560
Hardware: Unspecified Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Grant Gainey
QA Contact: Red Hat Satellite QA List
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 462714
TreeView+ depends on / blocked
 
Reported: 2013-06-02 23:21 UTC by Anderson Kaiser
Modified: 2015-05-29 20:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-05-29 20:11:15 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Anderson Kaiser 2013-06-02 23:21:32 UTC
Description of problem:

Oracle service do not check the mount point status and give wrong status during start / restart.

When you umount the /rhnsat directory for administrative propose (i.e. resize the lvm or any other procedure) when you start the oracle it shows "OK" to rhnsat instance where it should be "FAILED"

Version-Release number of selected component (if applicable):

RHN Satellite 5.5 (Embeded Database). 

How reproducible:

Always

Steps to Reproduce:
1. Stop the Satellite Service
# rhn-satellite stop

2. Umount the /rhnsat directory
# umount /rhnsat

3. Start only Oracle Service

# service oracle start

Actual results:

[root@satellite ~]# service oracle start
Starting Oracle Net Listener ...                           [  OK  ]
Starting Oracle DB instance "rhnsat" ...                   [  OK  ]

Expected results:

[root@satellite ~]# service oracle start
Starting Oracle Net Listener ...                           [  OK  ]
Starting Oracle DB instance "rhnsat" ...                   [FAILED]

Oracle should check the database location and don't show OK if it is not acessible.

Additional info:

When you stop, it show it as FAILED, as expecte since the instance is not running:

[root@satellite ~]# service oracle stop
Shutting down Oracle Net Listener ...                      [  OK  ]
Shutting down Oracle DB instance "rhnsat" ...              [FAILED]

Also you can see the information when you ask for a service status:

[root@satellite ~]# service oracle status
Oracle Net Listener (pid 5572) is running...
Oracle DB instance rhnsat is stopped


Note You need to log in before you can comment on or make changes to this bug.