Bug 969894 - Does not parse the AccountHash correctly from config file
Does not parse the AccountHash correctly from config file
Product: Fedora
Classification: Fedora
Component: afraid-dyndns (Show other bugs)
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Orphan Owner
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2013-06-02 19:57 EDT by Dmitri Brengauz
Modified: 2015-06-29 07:59 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2015-06-29 07:59:00 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
Patch to fix AccountHash error (3.21 KB, patch)
2013-06-23 15:52 EDT, tengel
no flags Details | Diff

  None (edit)
Description Dmitri Brengauz 2013-06-02 19:57:54 EDT
Description of problem:  upon install and configuration of this package, the script returns the following error when run:
$ afraid-dyndns
No AccountHash in configuration file - please see README for instructions. Done at /usr/bin/afraid-dyndns line 62.

This is the same problem as was seen on the program's Github page:

Version-Release number of selected component (if applicable):

How reproducible:  install, configure run

Additional info:

When I installed the script from the Github repo, I ran it without configuring the AccountHash variable.  It errored out at a different line (71) which made me think that the version of the script in the repo is outdated.   However, whilst the new script ran just fine, it required the additional installation of perl-MIME-Light package, so probably the dependencies need to be updated as well.
Comment 1 tengel 2013-06-23 15:50:49 EDT
The downloaded tarball script matches what the RPM installs. I tried installing perl-MIME-Lite as you noted and that didn't do it -- but, I found this patch which rewrites that loop:


I applied that patch to a test copy (it applies cleanly), the software now works as expected and updates my IP. It changes a bit more than just this loop FYI -- I'll attach a fresh patch based on theirs I regenerated to ensure it was clean against the RPM from Fedora.
Comment 2 tengel 2013-06-23 15:52:45 EDT
Created attachment 764371 [details]
Patch to fix AccountHash error

Regenerated patch from http://chakra-linux.org/ccr/diff_view.php?p=afraid-dyndns&d=afraid-dyndns-latest-fix.patch

NOTE: this patch also changes the server used to retrieve the IP
Comment 3 Fedora End Of Life 2013-09-16 10:04:13 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 20 development cycle.
Changing version to '20'.

More information and reason for this action is here:
Comment 4 Fedora End Of Life 2015-05-29 05:05:37 EDT
This message is a reminder that Fedora 20 is nearing its end of life.
Approximately 4 (four) weeks from now Fedora will stop maintaining
and issuing updates for Fedora 20. It is Fedora's policy to close all
bug reports from releases that are no longer maintained. At that time
this bug will be closed as EOL if it remains open with a Fedora  'version'
of '20'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version.

Thank you for reporting this issue and we are sorry that we were not 
able to fix it before Fedora 20 is end of life. If you would still like 
to see this bug fixed and are able to reproduce it against a later version 
of Fedora, you are encouraged  change the 'version' to a later Fedora 
version prior this bug is closed as described in the policy above.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.
Comment 5 Fedora End Of Life 2015-06-29 07:59:00 EDT
Fedora 20 changed to end-of-life (EOL) status on 2015-06-23. Fedora 20 is
no longer maintained, which means that it will not receive any further
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen this bug against that version. If you
are unable to reopen this bug, please file a new report against the
current release. If you experience problems, please add a comment to this

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.