Bug 969904 - Saving a gpg encrypted file fails because pressing enter causes the Passphrase dialog box to close and not re-appear to confirm the password.
Saving a gpg encrypted file fails because pressing enter causes the Passphras...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: emacs (Show other bugs)
18
Unspecified Linux
unspecified Severity medium
: ---
: ---
Assigned To: Petr Hracek
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-02 21:01 EDT by Noel Duffy
Modified: 2013-08-26 02:29 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-26 02:29:51 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Noel Duffy 2013-06-02 21:01:27 EDT
Description of problem: 

Using GNU Emacs  on Fedora 18, if you attempt to save a GPG encrypted file and press Enter after typing the correct password in the Gnome "Enter Passphrase" dialog box, the dialog box closes but Emacs reports in its message area: Opening output file: Encrypt failed, Exit

The problem is that pressing Enter closes the Passphrase dialog box prematurely. If you click the Unlock button instead of pressing Enter, the dialog closes and re-appears, asking you to confirm the password, at which time Emacs then correctly saves the file.

Version-Release number of selected component (if applicable): emacs-24.2-18.fc18.x86_64

How reproducible: Always


Steps to Reproduce:
1. Create a file and encrypt it using gpg with a symmetric cipher using a passphrase. E.g, echo test > foo.txt; gpg -c foo.txt
2. Open the file in GNU emacs. Enter passphrase to decrypt.
3. Modify, then hit Ctrl-X Ctrl-S to save. Enter passphrase in Gnome dialog, then press Enter. Dialog box closes, does not re-prompt for confirmation, Emacs refuses to save the file.

Actual results: 

Pressing Enter causes the Enter Passphrase dialog to close without confirming the password, so Emacs fails to save the file.

Expected results:

Pressing Enter should cause the dialog to re-appear to confirm the user password, at which point Emacs should then save the file.

Additional info:
Comment 1 Petr Hracek 2013-08-20 11:20:52 EDT
I tested the bug but unable to reproduced.
version on my F18 is emacs-24.2-20.fc18.x86_64

As you mentioned file has been modified and during the save action
two dialogs were opened (one for entering passphrase and second one for passphrase confirmation).

Do you have still the problem with encprypted files?
Comment 2 Noel Duffy 2013-08-23 20:12:58 EDT
(In reply to Petr Hracek from comment #1)
> I tested the bug but unable to reproduced.
> version on my F18 is emacs-24.2-20.fc18.x86_64
> 
> As you mentioned file has been modified and during the save action
> two dialogs were opened (one for entering passphrase and second one for
> passphrase confirmation).
> 
> Do you have still the problem with encprypted files?

I re-tried using emacs-24.2-20.fc18.x86_64 and the "confirm password" dialog now appears when I press enter. The problem appears to have been fixed.
Comment 3 Petr Hracek 2013-08-26 02:29:51 EDT
Because of I can not reproduce that bug closing with CLOSE->NOTABUG

Note You need to log in before you can comment on or make changes to this bug.