Bug 969911 - Custom addon cartridges have no way to get access to app code in scaled apps
Custom addon cartridges have no way to get access to app code in scaled apps
Status: CLOSED NOTABUG
Product: OpenShift Online
Classification: Red Hat
Component: Containers (Show other bugs)
2.x
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Jhon Honce
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-02 21:39 EDT by Clayton Coleman
Modified: 2015-05-14 19:20 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-03 11:09:26 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Clayton Coleman 2013-06-02 21:39:15 EDT
This may be a feature request, but I'm not sure if it's working as intended.  On non web-framework gears in scaled apps the app-root/runtime/repo directory is empty.  This means custom cartridges cannot use config files defined by the app.

If this not just a bug, it should be a fairly high priority story.
Comment 1 Jhon Honce 2013-06-03 11:09:26 EDT
This is currently not done to improve performance when deploying across gears.
Comment 2 Paul Morie 2013-06-03 11:39:04 EDT
Created card: https://trello.com/c/wduaR85v

Note You need to log in before you can comment on or make changes to this bug.