Bug 969917 - Cannot login after upgrade from f18 to F19 beta using fedup
Cannot login after upgrade from f18 to F19 beta using fedup
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: gnome-bluetooth (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Bastien Nocera
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-02 22:54 EDT by Wei Shen
Modified: 2014-06-22 21:33 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-11 09:17:00 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
fedup.log from f19 beta upgrade (679.82 KB, text/x-log)
2013-06-06 08:46 EDT, Brian Hamrick
no flags Details

  None (edit)
Description Wei Shen 2013-06-02 22:54:04 EDT
Description of problem:
I was using Fedup to upgrade my F18 Laptop to F19 beta, the whole process went smoonthly, but after rebooting, and input my username and password, there is an error saying: Oh no! something has gone wrong.
A problem has occured and the system can't recover. All extensions have been disabled as a precaution.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. fedup --network 19
2. after rebooting, input username and password
3. error occured

Actual results:
Error occurs

Expected results:
I should be able to login successfully.

Additional info:
Comment 1 Wei Shen 2013-06-02 23:20:28 EDT
I think the problem is gnome-shell failed to start, I could not find gnome-shell process. After running gnome-shell in teminal manually, the error still occured.
I can see another error:
Bluetooth:ERROR:rfkill-glib.c:83:type_to_string: code should not be reached Aborted
Comment 2 Brian Hamrick 2013-06-06 08:45:54 EDT
I have his this issue as well, with the same flow and error message.

Fedup.log fails during cleanup with this traceback:
[     0.188] (II) fedup:<module>() Exception:
Traceback (most recent call last):
  File "/usr/bin/fedup-cli", line 181, in <module>
    main(args)
  File "/usr/bin/fedup-cli", line 82, in main
    do_cleanup(args)
  File "/usr/lib/python2.7/site-packages/fedup/commandline.py", line 183, in do_cleanup
    remove_cache()
  File "/usr/lib/python2.7/site-packages/fedup/sysprep.py", line 195, in remove_cache
    rm_rf(d)
  File "/usr/lib/python2.7/site-packages/fedup/util.py", line 51, in rm_rf
    rm_f(d, rm=rmtree)
  File "/usr/lib/python2.7/site-packages/fedup/util.py", line 48, in rm_f
    log.warn("failed to remove %s: %s", f, str(e))
NameError: global name 'log' is not defined
[     0.188] (II) fedup:<module>() /usr/bin/fedup-cli exiting at Wed Jun  5 12:38:49 2013

But I don't know if that's relevant.  I suspect what Wei is reporting, that it's a gnome-shell issue, as I can login to a terminal fine.
Comment 3 Brian Hamrick 2013-06-06 08:46:40 EDT
Created attachment 757674 [details]
fedup.log from f19 beta upgrade
Comment 4 Ray Strode [halfline] 2013-06-06 09:27:09 EDT
This appears to be a gnome-bluetooth bug that has been fixed in git:

https://git.gnome.org/browse/gnome-bluetooth/commit/lib/rfkill-glib.c?id=9932a6316be777d47b89323c9b8ae132c3676830
Comment 5 Will Woods 2013-06-07 12:47:51 EDT
(In reply to Brian Hamrick from comment #2) 
> Fedup.log fails during cleanup with this traceback:
> [...]
> NameError: global name 'log' is not defined
> [     0.188] (II) fedup:<module>() /usr/bin/fedup-cli exiting at Wed Jun  5
> 12:38:49 2013
> 
> But I don't know if that's relevant.

That's bug 958586, and yes, it's unrelated.
Comment 6 Wei Shen 2013-06-07 22:47:48 EDT
(In reply to Ray Strode [halfline] from comment #4)
> This appears to be a gnome-bluetooth bug that has been fixed in git:
> 
> https://git.gnome.org/browse/gnome-bluetooth/commit/lib/rfkill-glib.
> c?id=9932a6316be777d47b89323c9b8ae132c3676830

I have disabled the bluetooth service, and login again, the same issue still happens
Comment 7 Wei Shen 2013-06-07 22:58:16 EDT
(In reply to Ray Strode [halfline] from comment #4)
> This appears to be a gnome-bluetooth bug that has been fixed in git:
> 
> https://git.gnome.org/browse/gnome-bluetooth/commit/lib/rfkill-glib.
> c?id=9932a6316be777d47b89323c9b8ae132c3676830

Yes, you are right, this issue disappear after I updated gnome-bluetooth to 3.8.1-1

Note You need to log in before you can comment on or make changes to this bug.