Bug 969922 - Foreman configuration now uses a config script
Foreman configuration now uses a config script
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Docs User Guide (Show other bugs)
6.0.1
Unspecified Unspecified
unspecified Severity unspecified (vote)
: Unspecified
: --
Assigned To: Athene Chan
Dan Macpherson
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-03 00:00 EDT by Dan Macpherson
Modified: 2015-05-11 18:09 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-04-24 13:09:36 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dan Macpherson 2013-06-03 00:00:11 EDT
Topic 15971 needs to be updated to specify the use of the foreman-proxy-configure script. For example:

# foreman-proxy-configure -db --servername 192.168.100.1 --port 9090 --puppet true --puppetca false --dhcp true  --dhcp-interface virbr1 --dns false --dns-interface false --tftp true

Probably might be a good idea to also move the proxy installation and configuration topics (15977, 15966, 15971, 15983) to the Install Guide.

Note: as a side issue, we need to specify the --port as 9090. foreman-proxy defaults to 8443, which conflicts with Candlepin, so it needs to be changed. The developers use 9090 and, for consistency, we should too .
Comment 1 RHEL Product and Program Management 2013-06-12 14:33:58 EDT
Since this issue was entered in Red Hat Bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.
Comment 3 Mike McCune 2013-08-16 14:21:33 EDT
getting rid of 6.0.0 version since that doesn't exist
Comment 6 Dan Macpherson 2013-09-29 20:45:59 EDT
Verified section for foreman-proxy-configure command.
Comment 7 Bryan Kearney 2014-04-24 13:09:36 EDT
This was verified and delivered with MDP2. Closing it out.
Comment 8 Bryan Kearney 2014-04-24 13:11:03 EDT
This was delivered and verified with MDP2. Closing the bug.

Note You need to log in before you can comment on or make changes to this bug.