This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 969973 - [abrt] hplip-3.13.5-1.fc19: pexpect.py:468:__spawn:OSError: [Errno 13] Operace zam?tnuta
[abrt] hplip-3.13.5-1.fc19: pexpect.py:468:__spawn:OSError: [Errno 13] Operac...
Status: CLOSED EOL
Product: Fedora
Classification: Fedora
Component: hplip (Show other bugs)
19
i686 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Tim Waugh
Fedora Extras Quality Assurance
abrt_hash:8003b958de7d023a29085481a75...
: Reopened
: 984348 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-03 04:28 EDT by Jiří Martínek
Modified: 2015-02-18 08:55 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-02-18 08:55:10 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (899 bytes, text/plain)
2013-06-03 04:28 EDT, Jiří Martínek
no flags Details
File: core_backtrace (523 bytes, text/plain)
2013-06-03 04:28 EDT, Jiří Martínek
no flags Details
File: environ (2.86 KB, text/plain)
2013-06-03 04:28 EDT, Jiří Martínek
no flags Details

  None (edit)
Description Jiří Martínek 2013-06-03 04:28:29 EDT
Version-Release number of selected component:
hplip-3.13.5-1.fc19

Additional info:
reporter:       libreport-2.1.4
cmdline:        /usr/bin/python /usr/bin/hp-doctor
dso_list:       hplip-gui-3.13.5-1.fc19.i686
executable:     /usr/bin/hp-doctor
kernel:         3.9.4-300.fc19.i686
runlevel:       N 5
uid:            1000

Truncated backtrace:
pexpect.py:468:__spawn:OSError: [Errno 13] Operace zam?tnuta

Traceback (most recent call last):
  File "/usr/bin/hp-doctor", line 289, in <module>
    num_errors, num_warns = core.validate(DEPENDENCY_RUN_AND_COMPILE_TIME, False)
  File "/usr/share/hplip/check.py", line 400, in validate
    installed_ver = get_version(self.hplip_dependencies[s][d][5])
  File "/usr/share/hplip/installer/dcheck.py", line 250, in get_version
    status, output = utils.run(cmd)
  File "/usr/share/hplip/base/utils.py", line 1244, in run
    child = pexpect.spawn(cmd, timeout=timeout)
  File "/usr/share/hplip/base/pexpect.py", line 369, in __init__
    self.__spawn()
  File "/usr/share/hplip/base/pexpect.py", line 468, in __spawn
    os.execv(self.command, self.args)
OSError: [Errno 13] Operace zam?tnuta

Local variables in innermost frame:
i: 1023
self: <base.pexpect.spawn object at 0x8c558cc>
max_fd: 1024L
Comment 1 Jiří Martínek 2013-06-03 04:28:33 EDT
Created attachment 756180 [details]
File: backtrace
Comment 2 Jiří Martínek 2013-06-03 04:28:37 EDT
Created attachment 756181 [details]
File: core_backtrace
Comment 3 Jiří Martínek 2013-06-03 04:28:41 EDT
Created attachment 756182 [details]
File: environ
Comment 4 Jiri Popelka 2013-06-03 10:44:04 EDT
Thanks for the report Jirko :)
We've already seen this backtrace couple times, but haven't had a clue what causes it.

Are you able to reproduce it ?

*** This bug has been marked as a duplicate of bug 903669 ***
Comment 5 Jiří Martínek 2013-06-04 06:42:56 EDT
Hi Jirko ;-)
I was trying to solve faxing problems with hp-doctor. It said, that quite a lot of my packages aren't compatible (F19). I think F19 is too new for hp-doctor. To reproduce it, just run hp-doctor on F19.

Thank you very much ;-)
J.M.

(In reply to Jiri Popelka from comment #4)
> Thanks for the report Jirko :)
> We've already seen this backtrace couple times, but haven't had a clue what
> causes it.
> 
> Are you able to reproduce it ?
> 
> *** This bug has been marked as a duplicate of bug 903669 ***
Comment 6 Jiri Popelka 2013-06-04 07:05:09 EDT
Yes, running hp-doctor from hplip-3.13.5-1.fc19 does the trick.

I can take a look at it, but I guess it's because Fedora 19 is considered not yet supported in 3.13.5 - HPLIP upstream has never understood how the downstream<->upstream work and they try to do all the packaging/installing/checking themselves.
Comment 7 Jiri Popelka 2013-07-15 09:09:11 EDT
*** Bug 984348 has been marked as a duplicate of this bug. ***
Comment 8 Jiri Popelka 2013-07-23 07:02:38 EDT
(In reply to Jiri Popelka from comment #6)
> I guess it's because Fedora 19 is considered not yet supported in 3.13.5

It's the same with 3.13.7 which claims to support F19.
Comment 9 Fedora End Of Life 2015-01-09 17:08:09 EST
This message is a notice that Fedora 19 is now at end of life. Fedora 
has stopped maintaining and issuing updates for Fedora 19. It is 
Fedora's policy to close all bug reports from releases that are no 
longer maintained. Approximately 4 (four) weeks from now this bug will
be closed as EOL if it remains open with a Fedora 'version' of '19'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version.

Thank you for reporting this issue and we are sorry that we were not 
able to fix it before Fedora 19 is end of life. If you would still like 
to see this bug fixed and are able to reproduce it against a later version 
of Fedora, you are encouraged  change the 'version' to a later Fedora 
version prior this bug is closed as described in the policy above.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.
Comment 10 Fedora End Of Life 2015-02-18 08:55:10 EST
Fedora 19 changed to end-of-life (EOL) status on 2015-01-06. Fedora 19 is
no longer maintained, which means that it will not receive any further
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen this bug against that version. If you
are unable to reopen this bug, please file a new report against the
current release. If you experience problems, please add a comment to this
bug.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.