Bug 970021 - Drop java dependency
Drop java dependency
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: libreoffice (Show other bugs)
rawhide
All Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Caolan McNamara
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-03 06:43 EDT by Heiko Adams
Modified: 2013-06-03 07:31 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-03 07:31:37 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Heiko Adams 2013-06-03 06:43:44 EDT
Description of problem:
LibreOffice currently depends on Java even if it has an option to disable the usage of Java. So IMHO there is no reason to pull in Java as a dependency even for security concerns it should be possible to install LO without Java. If a user still needs Java depending features of LO he still could install Java.
Comment 1 David Tardon 2013-06-03 07:31:37 EDT
(In reply to Heiko Adams from comment #0)
> LibreOffice currently depends on Java even if it has an option to disable
> the usage of Java. So IMHO there is no reason to pull in Java as a
> dependency even for security concerns it should be possible to install LO
> without Java. If a user still needs Java depending features of LO he still
> could install Java.

That is a fallacy. By that reasoning there should be no dependencies on anyting that is used dynamically, which includes dlopened libraries. If you want to disable java, just do it. I am really not interested in getting a slew of bug reports like "I cannot install this or that extension. It says 'Could not create Java implementation loader'".

Note You need to log in before you can comment on or make changes to this bug.