Bug 970028 - Show backtrace when using rhc combine with pipe and grep on Windows
Show backtrace when using rhc combine with pipe and grep on Windows
Status: CLOSED CURRENTRELEASE
Product: OpenShift Online
Classification: Red Hat
Component: Command Line Interface (Show other bugs)
2.x
Unspecified Unspecified
medium Severity low
: ---
: ---
Assigned To: Clayton Coleman
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-03 07:04 EDT by Meng Bo
Modified: 2015-05-14 22:23 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-11 00:16:04 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Meng Bo 2013-06-03 07:04:53 EDT
Description of problem:
Install rhc client on Windows with gem install.
Try to use rhc command combine with grep will get backtrace error.

$ rhc domain show -predhat |grep http

Version-Release number of selected component (if applicable):
rhc-1.9.6

How reproducible:
always

Steps to Reproduce:
1.Install rhc-1.9.6 on Windows via gem install
2.Try to use rhc command with pipe and grep
$ rhc domain show -predhat |grep http

Actual results:
$ rhc domain show -p123123 |grep ruby
DL is deprecated, please use Fiddle
c:/Ruby200-x64/lib/ruby/gems/2.0.0/gems/rhc-1.9.6/lib/rhc/highline_extensions.rb
:279:in `*': no implicit conversion from nil to integer (TypeError)
        from c:/Ruby200-x64/lib/ruby/gems/2.0.0/gems/rhc-1.9.6/lib/rhc/highline_
extensions.rb:279:in `block in rows'
        from c:/Ruby200-x64/lib/ruby/gems/2.0.0/gems/rhc-1.9.6/lib/rhc/highline_
extensions.rb:278:in `tap'
        from c:/Ruby200-x64/lib/ruby/gems/2.0.0/gems/rhc-1.9.6/lib/rhc/highline_
extensions.rb:278:in `rows'
        from c:/Ruby200-x64/lib/ruby/gems/2.0.0/gems/rhc-1.9.6/lib/rhc/highline_
extensions.rb:70:in `say'
        from c:/Ruby200-x64/lib/ruby/gems/2.0.0/gems/rhc-1.9.6/lib/rhc/highline_
extensions.rb:102:in `header'
        from c:/Ruby200-x64/lib/ruby/gems/2.0.0/gems/rhc-1.9.6/lib/rhc/helpers.r
b:257:in `block (2 levels) in <module:Helpers>'
        from c:/Ruby200-x64/lib/ruby/gems/2.0.0/gems/rhc-1.9.6/lib/rhc/output_he
lpers.rb:38:in `block in display_app'
        from c:/Ruby200-x64/lib/ruby/gems/2.0.0/gems/rhc-1.9.6/lib/rhc/highline_
extensions.rb:177:in `call'
        from c:/Ruby200-x64/lib/ruby/gems/2.0.0/gems/rhc-1.9.6/lib/rhc/highline_
extensions.rb:177:in `section'
        from c:/Ruby200-x64/lib/ruby/gems/2.0.0/gems/rhc-1.9.6/lib/rhc/highline_
extensions.rb:191:in `paragraph'
        from c:/Ruby200-x64/lib/ruby/gems/2.0.0/gems/rhc-1.9.6/lib/rhc/helpers.r
b:257:in `block (2 levels) in <module:Helpers>'
        from c:/Ruby200-x64/lib/ruby/gems/2.0.0/gems/rhc-1.9.6/lib/rhc/output_he
lpers.rb:37:in `display_app'
        from c:/Ruby200-x64/lib/ruby/gems/2.0.0/gems/rhc-1.9.6/lib/rhc/commands/
domain.rb:64:in `block (2 levels) in show'
        from c:/Ruby200-x64/lib/ruby/gems/2.0.0/gems/rhc-1.9.6/lib/rhc/commands/
domain.rb:63:in `each'
        from c:/Ruby200-x64/lib/ruby/gems/2.0.0/gems/rhc-1.9.6/lib/rhc/commands/
domain.rb:63:in `block in show'
        from c:/Ruby200-x64/lib/ruby/gems/2.0.0/gems/highline-1.6.18/lib/highlin
e.rb:676:in `indent'
        from c:/Ruby200-x64/lib/ruby/gems/2.0.0/gems/rhc-1.9.6/lib/rhc/highline_
extensions.rb:104:in `header'
        from c:/Ruby200-x64/lib/ruby/gems/2.0.0/gems/rhc-1.9.6/lib/rhc/helpers.r
b:257:in `block (2 levels) in <module:Helpers>'
        from c:/Ruby200-x64/lib/ruby/gems/2.0.0/gems/rhc-1.9.6/lib/rhc/commands/
domain.rb:62:in `show'
        from c:/Ruby200-x64/lib/ruby/gems/2.0.0/gems/rhc-1.9.6/lib/rhc/commands.
rb:241:in `execute'
        from c:/Ruby200-x64/lib/ruby/gems/2.0.0/gems/rhc-1.9.6/lib/rhc/commands.
rb:232:in `block (3 levels) in to_commander'
        from c:/Ruby200-x64/lib/ruby/gems/2.0.0/gems/commander-4.1.3/lib/command
er/command.rb:180:in `call'
        from c:/Ruby200-x64/lib/ruby/gems/2.0.0/gems/commander-4.1.3/lib/command
er/command.rb:155:in `run'
        from c:/Ruby200-x64/lib/ruby/gems/2.0.0/gems/commander-4.1.3/lib/command
er/runner.rb:400:in `run_active_command'
        from c:/Ruby200-x64/lib/ruby/gems/2.0.0/gems/rhc-1.9.6/lib/rhc/command_r
unner.rb:73:in `run!'
        from c:/Ruby200-x64/lib/ruby/gems/2.0.0/gems/commander-4.1.3/lib/command
er/delegates.rb:7:in `run!'
        from c:/Ruby200-x64/lib/ruby/gems/2.0.0/gems/rhc-1.9.6/lib/rhc/cli.rb:36
:in `start'
        from c:/Ruby200-x64/lib/ruby/gems/2.0.0/gems/rhc-1.9.6/bin/rhc:20:in `<t
op (required)>'
        from c:/Ruby200-x64/bin/rhc:23:in `load'
        from c:/Ruby200-x64/bin/rhc:23:in `<main>'

Expected results:
Should get the correct result.

Additional info:

$gem list
archive-tar-minitar (0.5.2)
bigdecimal (1.2.0)
commander (4.1.3)
highline (1.6.18)
httpclient (2.3.3)
io-console (0.4.2)
json (1.7.7)
minitest (4.3.2)
net-ssh (2.6.7)
open4 (1.3.0)
psych (2.0.0)
rake (0.9.6)
rdoc (4.0.0)
rhc (1.9.6, 1.9.4)
test-unit (2.0.0.0)
Comment 1 Clayton Coleman 2013-06-03 17:43:45 EDT
Fixed in https://github.com/openshift/rhc/pull/395
Comment 2 openshift-github-bot 2013-06-03 19:48:38 EDT
Commit pushed to master at https://github.com/openshift/rhc

https://github.com/openshift/rhc/commit/b2508675b99c9d4a5f6dcf36a1623748fbcc4833
Bug 970028 - Handle empty rows
Comment 3 Meng Bo 2013-06-04 02:40:09 EDT
Check the issue with rhc client which built from devenv_3313,

The issue is fixed.

rhc command combine with grep works well on Windows now.

Note You need to log in before you can comment on or make changes to this bug.