Bug 970053 - Bad error on running glance commands with malformed image ID
Bad error on running glance commands with malformed image ID
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-glanceclient (Show other bugs)
2.1
Unspecified Unspecified
medium Severity medium
: rc
: 4.0
Assigned To: Flavio Percoco
Tzach Shefi
storage
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-03 07:52 EDT by Daniel Paikov
Modified: 2016-04-26 23:06 EDT (History)
6 users (show)

See Also:
Fixed In Version: python-glanceclient-0.12.0-1.el6ost
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-19 19:04:22 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Launchpad 1178233 None None None Never
Launchpad 1190606 None None None Never
OpenStack gerrit 37825 None None None Never

  None (edit)
Description Daniel Paikov 2013-06-03 07:52:42 EDT
glance commands with a malformed image ID produce the following error:


[root@orange-vdsf ~(keystone_admin)]# glance image-delete 1
argument 2 to map() must support iteration

[root@orange-vdsf ~(keystone_admin)]# glance image-update 1 
argument 2 to map() must support iteration

[root@orange-vdsf ~(keystone_admin)]# glance image-download 1
argument 2 to map() must support iteration
Comment 6 Jakub Ruzicka 2013-11-20 07:17:53 EST
I've built python-glanceclient-0.12.0-1.el6ost which includes the upstream fix.
Comment 9 Dafna Ron 2013-12-11 12:34:11 EST
root@cougar06 ~(keystone_admin)]# glance image-delete 1234567890
Request returned failure status.
No image with a name or ID of '1234567890' exists.
[root@cougar06 ~(keystone_admin)]# 

moving to verified on 
openstack-glance-2013.2-4.el6ost.noarch
Comment 11 errata-xmlrpc 2013-12-19 19:04:22 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2013-1859.html

Note You need to log in before you can comment on or make changes to this bug.