Bug 970074 - glance member-list --tenant-id with non-existant ID produces no output
glance member-list --tenant-id with non-existant ID produces no output
Status: CLOSED WONTFIX
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-glanceclient (Show other bugs)
2.1
Unspecified Unspecified
medium Severity medium
: ---
: 4.0
Assigned To: Flavio Percoco
Haim
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-03 08:25 EDT by Daniel Paikov
Modified: 2016-04-26 15:56 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-10 07:10:40 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Daniel Paikov 2013-06-03 08:25:43 EDT
Searching for a member by tenant-id with a non-existant ID produces no indication of failure and no output:

[root@orange-vdsf ~(keystone_admin)]# glance member-list --tenant-id 1

[root@orange-vdsf ~(keystone_admin)]#
Comment 3 Flavio Percoco 2013-09-10 07:10:40 EDT
This is not a bug, Glance doesn't verify tenant's id. 

This behavior has been discussed many times upstream and as for now, I don't think it will be changed. I agree it's not nice the way it works from a user POV.

Perhaps, this could be raised again as part of the Icehouse development cycle.

Note You need to log in before you can comment on or make changes to this bug.