Bug 97010 - Kernel 2.4.20-18.9 and Kernel source 2.4.20-18.9 breaks Audigy sound card
Kernel 2.4.20-18.9 and Kernel source 2.4.20-18.9 breaks Audigy sound card
Status: CLOSED DUPLICATE of bug 97011
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
9
athlon Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-06-08 15:07 EDT by Need Real Name
Modified: 2007-04-18 12:54 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:56:38 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2003-06-08 15:07:56 EDT
Description of problem:
I upgraded Kernel and kernel sources from linux-2.4.20-13.9 to linux-2.4.20-18.9
went to my emu10k1 directory ran make clean - make - make - make install - make
tools - make install-tools got no errors but sound which had been working with
the previous kernel no longer worked - a reboot produced a number of logged
errors - also after this upgrade Galeon freezes when I submit a form or attempt
a search 

Version-Release number of selected component (if applicable):

kernel 2.4.20-18.9 kernel source 2.4.20-18.9

How reproducible:

Every time with this kernel

Steps to Reproduce:
1. Upgrade kernel and sources from 2.4.20-13.9 to 2.4.20-18.9
2. Make clean and recompile emu10k1 Audigy drivers - comment out lines referring
to the sound and aumix in the modules.conf file reboot - install the drivers
3. Reboot look at /var/log/messages for errors
    
Actual results:
From /var/log/messages with lines commented out of modules.conf to see results
with lines uncommnented please refer to bug # 91489
modprobe: Can't locate module sound-slot-0
modprobe: Can't locate module sound-service-0-3

i8253 count too high! resetting..

these messages repeat dozens of times for each reboot

No sound and a popup that informs me that aumix could not be loaded
Expected results:

sound to work and no error messages as has been my experience with each kernel
until this one


Additional info:

91489 seems to refer to the same problem on a previous kernel 

I had to comment out all the audigy amd aumix lines from modules.conf to file
this report as submission of forms freezes Galeon (and Mozilla)
Comment 1 Alan Cox 2003-06-09 10:29:23 EDT

*** This bug has been marked as a duplicate of 97011 ***
Comment 2 Red Hat Bugzilla 2006-02-21 13:56:38 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.