Bug 970118 - Wrong versions of dependencies in 6.1.0 final
Summary: Wrong versions of dependencies in 6.1.0 final
Status: CLOSED WONTFIX
Alias: None
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: Maven Repository (Show other bugs)
(Show other bugs)
Version: 6.1.0
Hardware: Unspecified Unspecified
unspecified
unspecified
Target Milestone: ---
: ---
Assignee: Paul Gier
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-06-03 13:40 UTC by Adam Kovari
Modified: 2015-09-01 03:03 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-10 21:29:34 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Adam Kovari 2013-06-03 13:40:42 UTC
Description of problem:
org/hibernate/hibernate-core/4.2.0.Final-redhat-1/hibernate-core-4.2.0.Final-redhat-1.pom

depends on dom4j:dom4j 1.6.1-redhat-4 but we package 1.6.1-redhat-5


org/jboss/component/management/jboss-component-version-master/6.1.0-redhat-1/jboss-component-version-master-6.1.0-redhat-1.pom:    <version.org.codehaus.jackson>1.9.9-redhat-1</version.org.codehaus.jackson>

should be 1.9.9-redhat-2

Comment 1 Paul Gier 2013-06-10 21:29:34 UTC
Unfortunately, there is not much we can do about the issue in the hibernate pom.  The version listed in the pom is the version that was used to build it.  It's expected that user builds include a dependency management pom which overrides transitive dependency version like this.

I think the version-master pom is correct, since the 1.9.9-redhat-1 version of jackson was the correct version when the version master pom was released.  The 6.1.0-redhat-2 version of the pom contains the 1.9.9-redhat-2 version of jackson.


Note You need to log in before you can comment on or make changes to this bug.