Bug 970237 - RHEVM-CLI: "power management user name" flag usage, wasn't updated as in help and auto complete
RHEVM-CLI: "power management user name" flag usage, wasn't updated as in help...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-restapi (Show other bugs)
3.2.0
Unspecified Unspecified
unspecified Severity medium
: ---
: 3.2.1
Assigned To: Ori Liel
Barak Dagan
infra
: Regression, ZStream
Depends On: 969097
Blocks: 977354
  Show dependency treegraph
 
Reported: 2013-06-03 15:08 EDT by Idith Tal-Kohen
Modified: 2016-02-10 14:40 EST (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Previously, a flag was changed from "power-management-username" to "power-management-user_name" in both help and auto-completion, however the CLI worked with the old name, while rejecting the new one. Now, the CLI has been updated so that the new flag name works correctly.
Story Points: ---
Clone Of: 969097
: 977354 (view as bug list)
Environment:
Last Closed: 2013-07-16 09:39:53 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Infra
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 15299 None None None Never
oVirt gerrit 15304 None None None Never
Red Hat Product Errata RHBA-2013:1048 normal SHIPPED_LIVE rhevm 3.2.1 bug fix update 2013-07-19 01:45:47 EDT

  None (edit)
Comment 4 Barak Dagan 2013-07-02 04:34:40 EDT
Verified on SF18.2

RSDL:

1) href="/api/hosts" rel="add">
<parameter required="false" type="xs:string"><name>host.power_management.username</name>
</parameter>

2) href="/api/hosts/{host:id}" rel="update">
<parameter required="false" type="xs:string"><name>host.power_management.username</name>
</parameter>

REST:

1) Update PM

PUT request content is --  url:api/hosts/24a98a45-c1e6-40b0-851d-f6e70aafaf7b body: <host>
<power_management type="apc_snmp">
<enabled>true</enabled>
<address>1.1.1.2</address>
<username>aaa</username>
<password>pswrd</password>
<options>
   <option name="slot" value="2"/>
</options>
<pm_proxies>
   <pm_proxy>
       <type>cluster</type>
   </pm_proxy>
   <pm_proxy>
     <type>dc</type>
   </pm_proxy>
</pm_proxies>

<agents>
	   <agent type="apc_snmp">
	   <address>1.1.1.2</address>
	   <username>aaa</username>
	   <password>pswrd</password>
	   <concurrent>false</concurrent>
	   <order>1</order>   
	   </agent>
</agents>
</power_management>
</host>
Comment 6 errata-xmlrpc 2013-07-16 09:39:53 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1048.html

Note You need to log in before you can comment on or make changes to this bug.