Bug 970240 - qemu-kvm guests lose connectivity to bridged network interface
qemu-kvm guests lose connectivity to bridged network interface
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: qemu (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Fedora Virtualization Maintainers
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-03 15:11 EDT by Dennis H
Modified: 2013-06-30 21:42 EDT (History)
12 users (show)

See Also:
Fixed In Version: qemu-1.2.2-13.fc18
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-30 21:42:10 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Launchpad 997978 None None None Never

  None (edit)
Description Dennis H 2013-06-03 15:11:55 EDT
Description of problem:

My Windows 7 qemu-kvm guest periodically loses connectivity to the bridged network adapter. It exactly matches the symptoms of this ubuntu bug https://bugs.launchpad.net/ubuntu/+source/qemu-kvm/+bug/997978.

The bug in ubuntu was resolved by incorporating these patches
   a821ce5 virtio: order index/descriptor reads
   92045d8 virtio: add missing mb() on enable notification
   a281ebc virtio: add missing mb() on notification

I know my bug report is very brief and I'm trying to piggyback off of an Ubuntu bug but please, please let me know what I need to provide to help resolve this in Fedora. Thanks!

Version-Release number of selected component (if applicable):

Fedora 18 3.9.4-200.fc18.x86_64
qemu-system-x86-1.2.2-11.fc18.x86_64
qemu-kvm-1.2.2-11.fc18.x86_64
ipxe-roms-qemu-20120328-2.gitaac9718.fc18.noarch
qemu-img-1.2.2-11.fc18.x86_64
qemu-common-1.2.2-11.fc18.x86_64
libvirt-daemon-driver-lxc-0.10.2.5-1.fc18.x86_64
libvirt-gconfig-0.1.5-1.fc18.x86_64
libvirt-daemon-driver-uml-0.10.2.5-1.fc18.x86_64
libvirt-daemon-driver-qemu-0.10.2.5-1.fc18.x86_64
libvirt-daemon-driver-nodedev-0.10.2.5-1.fc18.x86_64
libvirt-daemon-driver-secret-0.10.2.5-1.fc18.x86_64
libvirt-daemon-config-nwfilter-0.10.2.5-1.fc18.x86_64
libvirt-client-0.10.2.5-1.fc18.x86_64
libvirt-daemon-driver-storage-0.10.2.5-1.fc18.x86_64
libvirt-daemon-kvm-0.10.2.5-1.fc18.x86_64
libvirt-glib-0.1.5-1.fc18.x86_64
libvirt-daemon-driver-nwfilter-0.10.2.5-1.fc18.x86_64
libvirt-0.10.2.5-1.fc18.x86_64
libvirt-daemon-driver-network-0.10.2.5-1.fc18.x86_64
libvirt-gobject-0.1.5-1.fc18.x86_64
libvirt-daemon-driver-xen-0.10.2.5-1.fc18.x86_64
libvirt-daemon-0.10.2.5-1.fc18.x86_64
libvirt-python-0.10.2.5-1.fc18.x86_64
libvirt-daemon-driver-interface-0.10.2.5-1.fc18.x86_64
libvirt-daemon-driver-libxl-0.10.2.5-1.fc18.x86_64
libvirt-daemon-config-network-0.10.2.5-1.fc18.x86_64



Run command for VM:
LC_ALL=C PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin QEMU_AUDIO_DRV=none /usr/bin/qemu-kvm -name WIN7 -S -M pc-1.2 -enable-kvm -m 2920 -smp 2,sockets=2,cores=1,threads=1 -uuid 31c6d11b-7c01-d871-83f9-35767da19787 -no-user-config -nodefaults -chardev socket,id=charmonitor,path=/var/lib/libvirt/qemu/WIN7.monitor,server,nowait -mon chardev=charmonitor,id=monitor,mode=control -rtc base=localtime -no-shutdown -boot menu=off -device piix3-usb-uhci,id=usb,bus=pci.0,addr=0x1.0x2 -drive file=/home/local/share/vm/Windows 7 x64/Win7.img,if=none,id=drive-ide0-0-0,format=qcow2 -device ide-hd,bus=ide.0,unit=0,drive=drive-ide0-0-0,id=ide0-0-0,bootindex=1 -drive file=/dev/sr0,if=none,id=drive-ide0-1-0,readonly=on,format=raw -device ide-cd,bus=ide.1,unit=0,drive=drive-ide0-1-0,id=ide0-1-0 -netdev tap,fd=23,id=hostnet0 -device rtl8139,netdev=hostnet0,id=net0,mac=52:54:00:fe:82:14,bus=pci.0,addr=0x3 -chardev pty,id=charserial0 -device isa-serial,chardev=charserial0,id=serial0 -device usb-tablet,id=input0 -vnc 127.0.0.1:0 -vga std -device virtio-balloon-pci,id=balloon0,bus=pci.0,addr=0x4


How reproducible:

Every time, network connectivity cuts out about 30 minutes after booting the guest.

Steps to Reproduce:


Actual results:


Expected results:


Additional info:
Comment 1 Cole Robinson 2013-06-04 11:27:42 EDT
I don't think those patches will help you since they only affect virtio bits, which your guest isn't using.

There is a recent patch upstream that affects windows 7 and rtl8139 NIC:

commit 00b7ade807b5ce6779ddd86ce29c5521ec5c529a
Author: Stefan Hajnoczi <stefanha@redhat.com>
Date:   Wed May 22 14:50:18 2013 +0200

    rtl8139: flush queued packets when RxBufPtr is written

Maybe try changing the NIC model to e1000 and see if you can reproduce, might help narrow it down.
Comment 2 Stefan Hajnoczi 2013-06-05 06:23:54 EDT
(In reply to Cole Robinson from comment #1)
> There is a recent patch upstream that affects windows 7 and rtl8139 NIC:
> 
> commit 00b7ade807b5ce6779ddd86ce29c5521ec5c529a
> Author: Stefan Hajnoczi <stefanha@redhat.com>
> Date:   Wed May 22 14:50:18 2013 +0200
> 
>     rtl8139: flush queued packets when RxBufPtr is written

This looks like the right patch.  It fixes Windows 7 rtl8139 + tap network connectivity issues.
Comment 3 Fedora Update System 2013-06-11 16:16:13 EDT
qemu-1.2.2-12.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/qemu-1.2.2-12.fc18
Comment 4 Fedora Update System 2013-06-13 01:56:45 EDT
Package qemu-1.2.2-12.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing qemu-1.2.2-12.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-10724/qemu-1.2.2-12.fc18
then log in and leave karma (feedback).
Comment 5 Fedora Update System 2013-06-19 11:27:56 EDT
qemu-1.2.2-13.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/qemu-1.2.2-13.fc18
Comment 6 Fedora Update System 2013-06-30 21:42:10 EDT
qemu-1.2.2-13.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.